Palm sync problem : East Asian characters doesn't sync correctly.

RESOLVED DUPLICATE of bug 237624

Status

RESOLVED DUPLICATE of bug 237624
14 years ago
10 years ago

People

(Reporter: fly2thesun, Unassigned)

Tracking

1.7 Branch
x86
Windows 2000

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511

I'm using a Clie TJ27 and Palm desktop 4.1
As an East Asian, I have a lot of names in East Asian characters in the address
book, which are correctly displayed on the Clie and correctly synced between it
and the Palm desktop. But they don't correctly transfer between the Clie and the
Mozilla address book. A legible East Asian name on the Clie becomes something
like "¹Ú Àº¿µ" in Mozilla address book after sync. Likewise, legible East Asian
characters in Mozilla address book becomes cryptic on the Clie after sync. It
looks like palm sync has some problem with dealing with encoding, or it's
truncating 8-bit codes into 7-bit codes.

Reproducible: Always

Steps to Reproduce:
1. Make an entry with East Asian characters in Palm address book.
2. Sync with the Mozilla address book using palm sync.
Or,
1. Make an entry with East Asian characters in Mozilla address book.
2. Sync it with the Palm device using palm sync.

Actual Results:  
The original is okay ( i.e., no loss of data, and correct display of the
East Asian characters.. ),
but on the copy version, it's full of 'special characters', which are illegible,
like "¹Ú Àº¿µ".

Expected Results:  
The same East Asian character reading both on the original and the copy.
(Reporter)

Updated

14 years ago
Version: unspecified → 1.7 Branch
This is more likely a core palm sync problem, therefore changing product and
component & reassigning.
Assignee: mail → nobody
Component: Address Book → MailNews: Palm Sync
Product: Mozilla Application Suite → Core

Comment 2

14 years ago
dup of Bug 184297 ?

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 237624 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Updated

10 years ago
Component: Palm Sync → Palm Sync
Product: MailNews Core → MailNews Core Graveyard
You need to log in before you can comment on or make changes to this bug.