Closed Bug 294296 Opened 15 years ago Closed 13 years ago

misleading error message when 'domain not found'

Categories

(Thunderbird :: Mail Window Front End, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: davidmaxwaterman, Assigned: ch.ey)

References

Details

(Keywords: fixed1.8.1.1, regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I recently attemted to send an email to someone, but it failed due to 'Recipient
address rejected: Domain not found' (an intermittent problem at the root of it,
I guess).

The window that pops up says this :

"
An error occurred while sending mail. The mail server responded:
<...@...>: Recipient address rejected: Domain not found.
Please verify that your email address is correct in your Mail preferences and
try again.
"

I fail so see how *my* email address being correct (or otherwise) has any
bearing on the existence of the recipient's domain.

Is there no way to make the message more relevant to the error?

Reproducible: Always
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug is still relevant, I think. It should be trivial to fix too.
Which version of SM suite or Thunderbird?

(In reply to comment #0)
> I recently attemted to send an email to someone, but it failed due to
> 'Recipient
> address rejected: Domain not found' (an intermittent problem at the root of it,
> I guess).

do you still see the underlying problem?
would bug 88217 help?


> The window that pops up says this :
> 
> "
> An error occurred while sending mail. The mail server responded:
> <...@...>: Recipient address rejected: Domain not found.
> Please verify that your email address is correct in your Mail preferences and
> try again.
> "
> 
> I fail so see how *my* email address being correct (or otherwise) has any
> bearing on the existence of the recipient's domain.

do you still see this using trunk version or current release?
what do you suggest for rewording?
Severity: normal → minor
QA Contact: front-end
(In reply to comment #3)
> Which version of SM suite or Thunderbird?
> 
> (In reply to comment #0)
> > I recently attemted to send an email to someone, but it failed due to
> > 'Recipient
> > address rejected: Domain not found' (an intermittent problem at the root of it,
> > I guess).
> 
> do you still see the underlying problem?

The underlying problem is irrelevant, I think.

For example, I use fastmail - if I send an email to davidmax@fastmail.co.uk (I know such a person doesn't exist), then TB will check somehow that the destination address is valid before sending. It isn't valid, so it pops up the message, except with "Recipient address rejected: User unknown in local recipient table."

> would bug 88217 help?

I don't think that's relevant.

> 
> 
> > The window that pops up says this :
> > 
> > "
> > An error occurred while sending mail. The mail server responded:
> > <...@...>: Recipient address rejected: Domain not found.
> > Please verify that your email address is correct in your Mail preferences and
> > try again.
> > "
> > 
> > I fail so see how *my* email address being correct (or otherwise) has any
> > bearing on the existence of the recipient's domain.
> 
> do you still see this using trunk version or current release?

Yes. I am using 1.5.0.8 (20061025)

> what do you suggest for rewording?
> 

Well, instead of asking me to check my address, it should ask me to check the recipient's address :

"Alert

An error occurred while sending mail. The mail server responded: <emailaddress>: Recipient address rejected: User unknown in local recipient table. Please verify that the recipient email addresses are correct and try again."

Something like that.

Max.
Attached patch patchSplinter Review
Sorry, my fault. This is a regression introduced by patch for bug 210867.
Assignee: mscott → ch.ey
Status: UNCONFIRMED → ASSIGNED
Attachment #246181 - Flags: superreview?(bienvenu)
Comment on attachment 246181 [details] [diff] [review]
patch

I'll try to land this today, thx for the patch!
Attachment #246181 - Flags: superreview?(bienvenu) → superreview+
Blocks: 210867
Keywords: regression
OS: Mac OS X 10.2 → All
Hardware: Macintosh → All
Version: unspecified → 1.0
fixed on trunk and branch, thx, Christian!
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.