Firefox and Thunderbird load a lot of trash in the registry and don't clean it up again

RESOLVED FIXED

Status

()

Firefox
Installer
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: bugzillaspambox, Assigned: masayuki)

Tracking

unspecified
x86
Windows 2000
Points:
---
Bug Flags:
blocking-aviary1.0.5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Every Firefox and Thunderbird installation brings more and more trash in the
registry. I tried to remove the trash manually but after some time I gave up,
because the trash keeps comming with every update.

Have a look at my registry at the moment:
HKEY_CURRENT_USER\Software\Mozilla\Mozilla
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox\0.8. (en)
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox\0.9. (en)
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox\0.9.1 (en)
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox\0.9.2 (en)
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox\0.9.3 (en)
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox\1.0 (de-DE)
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox\1.0.1 (de-DE)
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox\1.0.4 (en-US)
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox\1.0PR (en-US)
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox\0.8. (en)
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox\0.9. (en)
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox\0.9.1 (en)
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox\0.9.2 (en)
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox\0.9.3 (en)
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox\1.0.4 (en-US)
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 0.9.3\bin
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 0.9.3\Extensions
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 0.9.3
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 0.9.3\bin
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 0.9.3\Extensions
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 0.9.3
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 1.0.2\bin
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 1.0.2\Extensions
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 1.0.2
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 1.0.2\bin
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 1.0.2\Extensions
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 1.0.2
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 1.0.3\bin
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 1.0.3\Extensions
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 1.0.3
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 1.0.3\bin
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 1.0.3\Extensions
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 1.0.3
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 1.0.4\bin
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 1.0.4\Extensions
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 1.0.4
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 1.0.4\bin
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 1.0.4\Extensions
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 1.0.4
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Thunderbird\1.0.2 (en)
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Thunderbird
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Thunderbird\1.0.2 (en)
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Thunderbird
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Thunderbird 0.8
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Thunderbird 0.8
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Thunderbird 0.9
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Thunderbird 0.9
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Thunderbird 1.0
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Thunderbird 1.0
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Thunderbird 1.0.2\bin
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Thunderbird 1.0.2
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Thunderbird 1.0.2\bin
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Thunderbird 1.0.2
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Thunderbird 1.0RC1
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Thunderbird 1.0RC1
HKEY_LOCAL_MACHINE\Software\Mozilla Thunderbird\Desktop
HKEY_CURRENT_USER\Software\Mozilla.org\Mozilla
HKEY_LOCAL_MACHINE\Software\Mozilla.org\Mozilla
HKEY_CURRENT_USER\Software\Mozilla.org\Mozilla Firefox\0.8. (de)
HKEY_CURRENT_USER\Software\Mozilla.org\Mozilla Firefox\0.8. (en)
HKEY_CURRENT_USER\Software\Mozilla.org\Mozilla Firefox
HKEY_LOCAL_MACHINE\Software\Mozilla.org\Mozilla Firefox\0.8. (de)
HKEY_LOCAL_MACHINE\Software\Mozilla.org\Mozilla Firefox\0.8. (en)
HKEY_LOCAL_MACHINE\Software\Mozilla.org\Mozilla Firefox
HKEY_CURRENT_USER\Software\Mozilla.org\Mozilla Thunderbird\0.6+. (en)
HKEY_CURRENT_USER\Software\Mozilla.org\Mozilla Thunderbird\0.6. (en)
HKEY_CURRENT_USER\Software\Mozilla.org\Mozilla Thunderbird\0.7. (en)
HKEY_CURRENT_USER\Software\Mozilla.org\Mozilla Thunderbird\0.7.1 (en)
HKEY_CURRENT_USER\Software\Mozilla.org\Mozilla Thunderbird\0.7.1. (de)
HKEY_CURRENT_USER\Software\Mozilla.org\Mozilla Thunderbird
HKEY_LOCAL_MACHINE\Software\Mozilla.org\Mozilla Thunderbird\0.6+. (en)
HKEY_LOCAL_MACHINE\Software\Mozilla.org\Mozilla Thunderbird\0.6. (en)
HKEY_LOCAL_MACHINE\Software\Mozilla.org\Mozilla Thunderbird\0.7. (en)
HKEY_LOCAL_MACHINE\Software\Mozilla.org\Mozilla Thunderbird\0.7.1 (en)
HKEY_LOCAL_MACHINE\Software\Mozilla.org\Mozilla Thunderbird\0.7.1. (de)
HKEY_LOCAL_MACHINE\Software\Mozilla.org\Mozilla Thunderbird

Do I really need all thouse entrys, especially thouse of the old versions? Do I
NEED anyone at all or couldn't that be solved a better way than filling my
registry? I hope you guys can fix that, so that new installations remove the
junk that I don't need anymore.

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
see bug 293866
(Assignee)

Updated

13 years ago
Status: UNCONFIRMED → NEW
Component: General → Installer
Ever confirmed: true
QA Contact: general → installer
*** Bug 293866 has been marked as a duplicate of this bug. ***
Same issue of suite is bug 264386.
(Reporter)

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 264386 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Why it is duped to 264386?
It is suite problem, so, the code is xpinstall.
But this is firefox and thunderbird problem, so, the code is
toolkit/mozapp/installer.
These causes differ.
(Reporter)

Comment 6

13 years ago
ok perhaps you are right, I reopened it.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Created attachment 183913 [details] [diff] [review]
Patch rv1.0
Assignee: nobody → masayuki
Status: REOPENED → ASSIGNED
Attachment #183913 - Flags: review?(benjamin)
(Assignee)

Updated

13 years ago
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.0.5?

Updated

13 years ago
Attachment #183913 - Flags: review?(benjamin) → review+
Comment on attachment 183913 [details] [diff] [review]
Patch rv1.0

The risk is low.
Attachment #183913 - Flags: approval-aviary1.1a1?
Attachment #183913 - Flags: approval-aviary1.0.5?

Comment 9

13 years ago
Comment on attachment 183913 [details] [diff] [review]
Patch rv1.0

a=asa for 1.1a1 checkin.
Attachment #183913 - Flags: approval-aviary1.1a1? → approval-aviary1.1a1+
checed in to trunk.
(Assignee)

Updated

13 years ago
Flags: blocking-aviary1.1?

Comment 11

13 years ago
Am I correct in that this patch doesn't fix any existing problems, only stops it
in the future? My procedure lately has been to just delete any Firefox,
Thunderbird, Firebird, Mozilla entries in the registry, and let the installer
put the latest. Is that a safe bet? Is there or should there be a tool or
utility or part of the program code to automatically fix this for us?
Flags: blocking-aviary1.1?
If you want to remove the old entries, you should use uninstaller.

Comment 13

13 years ago
(In reply to comment #12)
> If you want to remove the old entries, you should use uninstaller.

It doesn't work.
What is your trush in the registry?

The patch is removing immediately before version's
"HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 1.x" and
"HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox 1.x".

If you have another problem, you should file new bug.
(Reporter)

Comment 15

13 years ago
confirming comment #13, the uninstaller does not remove the trash
(In reply to comment #15)
> confirming comment #13, the uninstaller does not remove the trash

I cannot reproduce it.
I installed 1.0(en) -> 1.0.1(en) -> 1.0.2(en) -> 1.0.3(en) -> 1.0+(en) for this
test. And I used 1.0+'s uninstaller.
What's name of your 'trash'?

Comment 17

13 years ago
(In reply to comment #16)

The uninstaller removes the trash in the registry on my computer when I
uninstall it before updating, but... when I update Firefox from 1.0.3 to 1.0.4
without uninstalling, the trash remains.

Maybe the Firefox installer should automatically uninstall previous versions of
Firefox before updating, like other programs do.

Comment 18

13 years ago
If this was landed on the trunk it needs to be resolved Fixed. 
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Not blocking a security release
Flags: blocking-aviary1.0.5? → blocking-aviary1.0.5-

Updated

13 years ago
Flags: blocking-aviary1.1?

Comment 20

13 years ago
Comment on attachment 183913 [details] [diff] [review]
Patch rv1.0

1.0.5 has already shipped; removing approval request.
Attachment #183913 - Flags: approval-aviary1.0.5?

Comment 21

12 years ago
This one should be reopened for the latest nightly builds and have the other similar bugs duped to it.
You need to log in before you can comment on or make changes to this bug.