Last Comment Bug 294612 - xforms form elements are not working after a xslt transformation
: xforms form elements are not working after a xslt transformation
Status: RESOLVED WONTFIX
:
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: x86 Windows XP
: -- normal with 11 votes (vote)
: ---
Assigned To: xforms
: Stephen Pride
:
Mentors:
: 315009 (view as bug list)
Depends on: 239152
Blocks: 323593
  Show dependency treegraph
 
Reported: 2005-05-18 02:24 PDT by Andreas Fuerer
Modified: 2016-07-15 14:46 PDT (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
original XML file (86 bytes, text/xml)
2005-05-18 02:26 PDT, Andreas Fuerer
no flags Details
Example: XSL (813 bytes, text/xml)
2005-05-18 02:27 PDT, Andreas Fuerer
no flags Details
Same as original XML, but linked to the XSL attachment for easier testing (131 bytes, application/xml)
2006-03-21 14:12 PST, Orion Ifland
no flags Details

Description Andreas Fuerer 2005-05-18 02:24:30 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050201
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050201

XForms are not working after an XSLT transformation.
With XSLT I generated a XHTML which contains an XForms form. The XSL
transformation is done and rendered in the browser correctly. But the form can
not be edited and submission does not work. (see examples in "Steps to Reproduce").
If you save the transformed XHTML in a file and re-open it then it works
perfectly as it should.

Reproducible: Always

Steps to Reproduce:
=== EXAMPLE test.xsl ===
<?xml version="1.0"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
 xmlns:xf="http://www.w3.org/2002/xforms">
  
<xsl:output encoding="UTF-8" method="xml" />

<xsl:template match="result">
<html xmlns="http://www.w3.org/1999/xhtml"
xmlns:xf="http://www.w3.org/2002/xforms"
xmlns:ev="http://www.w3.org/2001/xml-events">
<head>
<title>Test</title>
 <xf:model>
	<xf:instance>
		<person xmlns="">
    		<name/>
		</person>
	</xf:instance>
	<xf:submission action="http://localhost/" method="post" id="submit"
includenamespaceprefixes="" />
  </xf:model>
</head>
<body>
<xf:input ref="name"><xf:label>Your name:</xf:label></xf:input>
<xf:submit submission="submit">
  <xf:label>Submit</xf:label>
</xf:submit>
</body>
</html>
</xsl:template>
</xsl:stylesheet>
================================

=== test.xml ===
<?xml version="1.0"?>
<?xml-stylesheet type="text/xsl" href="test.xsl" ?>
<result />
================================
Actual Results:  
XSL transformation is done and the document is rendered correctly in the
browser. But I can't edit the text field and nothing happens if I click on the
sumbit button.
Comment 1 Andreas Fuerer 2005-05-18 02:26:38 PDT
Created attachment 183894 [details]
original XML file
Comment 2 Andreas Fuerer 2005-05-18 02:27:19 PDT
Created attachment 183895 [details]
Example: XSL
Comment 3 Allan Beaufour 2005-05-26 00:09:28 PDT
I haven't looked at you specific case, but I've experienced it myself.

Jonas, this is the bug I talked about yesterday.
Comment 4 Allan Beaufour 2005-08-18 02:10:33 PDT
The elements are created correctly etc. but we fail to locate the instances and
the model I think. This might be because we look for them in the wrong document?
That is in the source-file, and not in the transformed document.
Comment 5 Jonas Sicking (:sicking) No longer reading bugmail consistently 2005-08-18 02:45:02 PDT
got an lxr-link to the code that fails?
Comment 6 Allan Beaufour 2005-08-20 01:24:52 PDT
(In reply to comment #5)
> got an lxr-link to the code that fails?

Nope, sorry. I'll try to look at it again some time, but it's not high on my
priority list.
Comment 7 Allan Beaufour 2005-09-02 10:34:26 PDT
I think I've found the problem. It's somewhat the same as bug 302915.
BeginAddingChildren() and DoneAddingChildren() are not called on XTF elements
when they are created by Transformiix.
Comment 8 Jonas Sicking (:sicking) No longer reading bugmail consistently 2005-09-26 12:28:18 PDT
Bug 239152 is about cleaning up the entire mess of the multiple notifications we
have now. We could either hack more notifications into transformiix, or wait for
the mess to be fixed once and for all.
Comment 9 Allan Beaufour 2005-11-05 00:53:16 PST
*** Bug 315009 has been marked as a duplicate of this bug. ***
Comment 10 Orion Ifland 2006-03-21 14:12:26 PST
Created attachment 215811 [details]
Same as original XML, but linked to the XSL attachment for easier testing
Comment 11 David Bolter [:davidb] 2016-02-04 12:21:07 PST
RIP xforms

Note You need to log in before you can comment on or make changes to this bug.