"dialog has no properties" error in the JavaScript console after closing download attachment dialog

VERIFIED FIXED in mozilla1.8.1

Status

()

Toolkit
Downloads API
--
trivial
VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: Julien Lecomte, Assigned: Dorando)

Tracking

Trunk
mozilla1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Open the JavaScript console, go to http://www.mozilla.org/, and click on 
the "Free Download" link (just an example...) A dialog is opened to ask you if 
you want to open or save the file. Just close the dialog using the "X" button. 
The error will appear 3 times in the JavaScript console.

Reproducible: Always
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050519
Firefox/1.0+ ID:2005051914

WFM (no errors)

Comment 2

13 years ago
I can reproduce on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050519 Firefox/1.0+
if pref javascript.options.showInConsole is set to true.

Looks like some sort of bug in the Download Manager code.
Status: UNCONFIRMED → NEW
Component: General → Download Manager
Ever confirmed: true
QA Contact: general → download.manager
Version: unspecified → Trunk

Comment 3

13 years ago
Version 2006-05-17

I didn't see the error that you mentioned, but whilst following
your recipe, I got this ASSERTION:

    OnDataAvailable implementation consumed no data 

at http://lxr.mozilla.org/mozilla/source/netwerk/base/src/nsInputStreamPump.cpp#459

Comment 4

13 years ago
I can reproduce in 
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.7) Gecko/20050414
Firefox/1.0.3

Occurs for open, save, or cancel.

Same for Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050730
Firefox/1.0+

HW, OS => ALL
Blocks: 296661
OS: Windows XP → All
Hardware: PC → All

Comment 6

13 years ago
I'm not seeing this in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050810 Firefox/1.0+ ID:2005081004

Can anyone with linux still reproduce?
(Assignee)

Comment 7

13 years ago
Created attachment 192984 [details] [diff] [review]
Checking if dialog exists before calling dialog.onBlur

This fixes it for me
Attachment #192984 - Flags: review?(mconnor)

Updated

13 years ago
Attachment #192984 - Flags: review?(mconnor) → review+
Whiteboard: [checkin needed]
Assignee: nobody → bugzilla-mozilla
Trunk:
mozilla/toolkit/mozapps/downloads/content/unknownContentType.xul;
new revision: 1.12;
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox1.6-
Severity: normal → trivial
Status: RESOLVED → VERIFIED
(Assignee)

Updated

13 years ago
Attachment #192984 - Flags: approval1.8b5?

Comment 9

13 years ago
Comment on attachment 192984 [details] [diff] [review]
Checking if dialog exists before calling dialog.onBlur

Per bug meeting - not approved for 1.8b5.
Attachment #192984 - Flags: approval1.8b5? → approval1.8b5-

Comment 10

12 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060316 Firefox/1.6a1

This dialogue does not have (or no longer has) a 'close button', but if comment 4
has full weight then 'Cancel' also reproduces the bug. There are currently no abnormal messages in the Javascript console, and given comment 7 and comment 8 ,
this bug is FIXED.

Note that when the "Opening ..." dialogue box is created, there is this message
in the log:

###!!! ASSERTION: If we have a txn pump, request must be it: '!mTransactionPump || request == mTransactionPump', file ../../../../../../src/netwerk/protocol/http/src/nsHttpChannel.cpp, line 4016

 
Duplicate of this bug: 313828
Duplicate of this bug: 389981
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.