"Clear" vs. "Empty" wording is inconsistent (cache/history in prefs vs menus)

RESOLVED FIXED in Camino1.5

Status

--
trivial
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: bugzilla-graveyard, Assigned: alqahira)

Tracking

({fixed1.8, polish})

unspecified
Camino1.5
PowerPC
macOS
fixed1.8, polish

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050517 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050517 Camino/0.8+

As mentioned recently on the MZ Forums, Camino has a minor inconsistency in its
wording. In Preferences, the option to clear history is worded as "Clear Visited
Pages" while in the Go menu, it is worded "Clear History."

Likewise, the Camino menu contains "Empty Cache", while preferences contains
"Clear Cache."

Reproducible: Always

Steps to Reproduce:

Actual Results:  
inconsistent wording

Expected Results:  
consistent wording
Seems reasonable.  Polish, maybe for 1.1?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
Summary: "Clear" vs. "Empty" wording is inconsistent → "Clear" vs. "Empty" wording is inconsistent (cache/history in prefs vs menus)
Target Milestone: --- → Camino1.1
Can we decide on which way we want to go for each (or should they both take the
same term)?  This seems like a pretty easy bit of polish we could sneak in, if
we had wording.

I tend to favor "Empty Cache" slightly because cache seems to me something like
trash, a repository of multiple files that gets emptied and refilled.  But if we
want only one verb, "Clear" is fine (both "Clear Cache" and "Clear Visited
Pages" are in the same prefpane).

"Visited pages" seems like the more entrenched term in that area and is
user-friendly, so that seems like the way to go.  Although that will require a
bit of work in the "Clear History..." dialogue (the other will require a bit of
work in the prefs; it's a toss-up, I think).
(Reporter)

Comment 3

14 years ago
Mike, Simon, Samuel? What say ye? Now that we've got two related bugs (bug 315886 and bug 315877), can we make a decision and knock all three of these out at once?

cl
I say we "Empty" cache, but "Clear Visited Pages". People who know what cache is probably understand what we mean by "Empty", whereas those clearing visited pages are getting a more thorough explanation. It should always be "clear" when we're talking about history, pages, etc, but "empty" when we're talking about cache (and other more technical terms). Cache and history aren't the same and we should use different terminology for each.

(In otherwords, change the one button in the prefs that says "Clear Cache" to "Empty Cache". Everything else stays the same.)
(In reply to comment #4)
> (In otherwords, change the one button in the prefs that says "Clear Cache" to
> "Empty Cache". Everything else stays the same.)

I'm fine with that for cache, but it still leaves us calling history "Visited Pages" in the prefs and "History" in the Go menu, which was the original complaint.

It's wierd either way, I think.
It needs to say History all around. We don't say "Show Visited Pages", but rather "Show History."
"Clear History" also keeps us in sync with the button title in the "are you sure?" dialogue that is shown when the menu is invoked (and will be shown in the prefPane once bug 315886 lands).

I'll attach a fixed History.nib shortly with these button changes.
Blocks: 315886
So the buttons are now "Clear History…" and "Empty Cache…" to be consistent with the Go and Camino menu items, respectively, and have the elipsis since they'll be getting the matching "Are you sure?" dialogues in bug 315886.
Attachment #202628 - Flags: superreview?(mikepinkerton)
(Reporter)

Comment 9

14 years ago
--> Smokey.

cl
Assignee: mikepinkerton → alqahira

Comment 10

14 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Attachment #202628 - Flags: superreview?(mikepinkerton)
You need to log in before you can comment on or make changes to this bug.