Closed Bug 296266 Opened 17 years ago Closed 14 years ago

SVG 1.1 Gradient Module feature string not supported

Categories

(Core :: SVG, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: codedread, Assigned: scootermorris)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050523 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050523 Firefox/1.0+

According to http://www.mozilla.org/projects/svg/status.html the Mozilla
implementation of SVG 1.1 supports the entire Gradient module
(http://www.w3.org/TR/SVG11/pservers.html#gradient-mod).  However, this simple
test tells me otherwise:

<?xml version="1.0"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg xmlns="http://www.w3.org/2000/svg" >
<switch>
    <text requiredFeatures="http://www.w3.org/TR/SVG11/feature#Shape" x="10" y="20">
        SVG 1.1 Shapes Module supported
    </text>
    <text x="10" y="20">SVG 1.1 Shape Module NOT supported</text>
</switch>
<switch>
    <text requiredFeatures="http://www.w3.org/TR/SVG11/feature#Gradient" x="10"
y="40">
        SVG 1.1 Gradient Module supported
    </text>
    <text x="10" y="40">SVG 1.1 Gradient Module NOT supported</text>
</switch>
</svg>

Did someone forget to add support for the
http://www.w3.org/TR/SVG11/feature#Gradient feature string or is Moz's
implementation of this module not complete?  Keeping up to date with supported
feature strings is important for conditional processing and providing friendly
degradable SVG content.

Reproducible: Always

Steps to Reproduce:
1.Perform conditional processing on the Gradient feature string
2.
3.
Actual Results:  
Switch did not choose the proper child element to match Gradient feature string.

Expected Results:  
Moz should support feature string http://www.w3.org/TR/SVG11/feature#Gradient
Yup, somebody (me) forgot about the feature string for gradients.  The *really*
sad part is that I was also the one that implemented the support for SVG feature
strings.  Sheesh!

Taking.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #185058 - Flags: review?(tor)
Attachment #185058 - Flags: review?(tor)
Attachment #185058 - Attachment is obsolete: true
Attachment #185066 - Flags: review?(tor)
Attachment #185066 - Flags: review?(tor) → review+
Attachment #185066 - Flags: approval1.8b3?
Scooter,

I'm comparing http://www.mozilla.org/projects/svg/status.html with
http://www.w3.org/TR/SVG11/feature.html against your second attachment.

According to status.html, the #Text module is not fully supported and should be
marked as such.  Can you please cross-check the rest of the modules before
submitting this bug?

Thanks,
Jeff
Here's another inconsistency:

 SVG_SUPPORTED_FEATURE("http://www.w3.org/TR/SVG11/feature#SVG")
 SVG_SUPPORTED_FEATURE("http://www.w3.org/TR/SVG11/feature#SVGDOM")
 SVG_UNSUPPORTED_FEATURE("http://www.w3.org/TR/SVG11/feature#SVG-static")
 SVG_UNSUPPORTED_FEATURE("http://www.w3.org/TR/SVG11/feature#SVGDOM-static")
 SVG_UNSUPPORTED_FEATURE("http://www.w3.org/TR/SVG11/feature#SVG-animation")
 SVG_UNSUPPORTED_FEATURE("http://www.w3.org/TR/SVG11/feature#SVGDOM-animation")

The SVG 1.1 spec (http://www.w3.org/TR/SVG11/feature.html) for #SVG states:

"At least one of ... #SVG-static, #SVG-animation, #SVG-dynamic or #SVGDOM."

You have marked "#SVGDOM" as supported however, the spec states that for #SVGDOM:

"At least one of the following ... #SVGDOM-static, #SVGDOM-animation or
#SVGDOM-dynamic"

None of which Moz yet supports.
Use this page to see all SVG feature strings and their level of support: 
http://www.codedread.com/svgtest.svg
Attachment #185066 - Flags: approval1.8b3? → approval1.8b3+
Assignee: general → scootermorris
Status: ASSIGNED → NEW
Checked in.

Checking in nsSVGFeaturesList.h;
/cvsroot/mozilla/content/svg/content/src/nsSVGFeaturesList.h,v  <-- 
nsSVGFeaturesList.h
new revision: 1.3; previous revision: 1.2
done
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Why were my comments #4 and #5 ignored here?  The latest build shows the
Gradient string supported, but as indicated by my comments, there are several
other inconsistencies in the feature strings that need to be fixed.  Do you want
me to open up separate bugs for each string???
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Jeff,
  My fault.  Somehow I missed your comments (the patch was already out for
review).  I'll take another look and make the necessary modifications, but keep
in mind that the SVG support in Gecko continues to advance and a change today
might certainly be out-of-date by tomorrow.  
Thanks, Scooter.  I am certainly not suggesting that what I see in Deer Park is 
the extent of what Firefox 1.1 will support for SVG (I hope I am pleasantly 
surprised come Fx 1.1 RC), but I am saying that Deer Park's supported feature 
strings are incorrect as they stand today.  This would be considered a bug 
because the feature strings are used by developers to enable certain features 
in their SVG content.  I would anticipate when a new SVG module is fully 
supported, then the feature string would be turned on as a last action by 
Mozilla developers.  Someone else may have a different opinion...
Fixed by check in for bug 322724.
Status: REOPENED → RESOLVED
Closed: 17 years ago14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.