Crash- Closing app if Mail has been opened during session.

VERIFIED FIXED

Status

MailNews Core
Backend
P3
critical
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: esther, Assigned: Kevin McCluskey (gone))

Tracking

({crash})

Trunk
All
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-]plus for beta2)

(Reporter)

Description

18 years ago
Uisng build 2000-02-29-09 on win98, if you have opened mail during a session of 
Seamonkey, when closing Browser you will crash.  

1. Launch Browser - 
2. Launch Mail (pop or imap) using menu or button
3. Close Mail using menu or button
4. Close Browser using menu or button
5. Crash 
Talkback incident 6072354
Call Stack
PresShell::CreateRenderingContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2160]
PresShell::ProcessReflowCommands 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2005]
ReflowEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1935]
PL_HandleEvent 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 527]
PL_ProcessPendingEvents 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 490]
_md_EventReceiverProc 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 977]
KERNEL32.DLL + 0x363b
   (0xbff7363b) 
KERNEL32.DLL + 0x242e7
   (0xbff942e7) 
0x00658bd2
(Reporter)

Comment 1

18 years ago
Note: this is a new bug, in bug 29644 for yesterday's build, user had to have 
mail +address book opened and closed using menus only.  This bug requires just 
mail to have been opened and using buttons or menus will cause the crash.  Note 
also that if you other windows (composer, address book, new message) but not 
mail you don't crash. 
Keywords: beta1, crash
QA Contact: lchiang → esther

Comment 2

18 years ago
this is a dup of the same bug that 29644 is a dup of.  When I find that bug I 
will mark this as a dup as well.  If you see more crashes closing with a similar 
stack to the one you have listed, it is just a dup of this same bug.

The good news is that whoever ends up fixing this will have a bunch of test 
cases.

Comment 3

18 years ago
I think this is a dup of 26926, but that bug is marked fixed and this still 
happens.  reassigning to nisheeth.
Assignee: putterman → nisheeth
(Reporter)

Comment 4

18 years ago
happens on linux too 2000-02-29-09
(Reporter)

Comment 5

18 years ago
happens on mac too 2000-02-29-09 mozilla build

Comment 6

18 years ago
Setting to ALL platforms.
Hardware: PC → All

Comment 7

18 years ago
Putting on PDT+ radar for beta1.  But will move to PDT- if not fixed by 03/03 or 
regression occurs.

Assigning to rickg to reassign since nisheeth out.
Assignee: nisheeth → rickg
Whiteboard: [PDT+] w/b minus on 03/03

Comment 8

18 years ago
*** Bug 29664 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
hmm, I would think twice before having a beta with this.  True, the crash is on 
exit, but it's very easy to get and makes our application look like it always 
crashes.  Also, certain prefs changed during the session may not be saved when 
crash on exit occurs.
(Reporter)

Comment 10

18 years ago
Using build 2000-03-01-09 on win98 and 2000-03-01-08 on linux this is now fixed. 
A similiar bug I logged 29644 was marked as duplicate of 26926.  29644 and this 
one are fixed, but duplicate bug is not resolved.  Was this a dup of 26944 too 
and was that bug fixed.  If so this can be resolved as dup, if not this can be 
resolved as worksforme.
(Reporter)

Comment 11

18 years ago
Correction:  was this a duplicate of 26926 too?

Comment 12

18 years ago
I wonder if it's really fixed or some randomness that causes this bug to appear. 
It's awfully strange to see this bug on some days and not on others.

Comment 13

18 years ago
Any relationship to bug 26653? They seem to be the same bug ...

Comment 14

18 years ago
Sounds like a strange intermittent bug.  The 3/3 date has passed, so I'm 
latering this to beta2 per status whiteboard.
Whiteboard: [PDT+] w/b minus on 03/03 → [PDT-]plus for beta2

Comment 15

18 years ago
add beta2 then to keyword.
Keywords: beta2

Comment 16

18 years ago
Kevin -- please triage this bug. Close it if you can't reproduce it.
Assignee: rickg → kmcclusk
(Assignee)

Comment 17

18 years ago
I can not reproduce the problem with 3/21/2000 build on WIN98 or WINNT.
Marking as fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

18 years ago
Using build 2000-03-29-09M15 on win98, this is not reproducible.  Verified.
Status: RESOLVED → VERIFIED

Comment 19

18 years ago
Putting on beta2 keyword radar since this was "plus for beta2" during beta1 
triaging

Updated

18 years ago
Keywords: nsbeta2
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.