If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tools - DOM Inspector doesn't inspect the current page anymore, Ctrl+Shift+I works

VERIFIED DUPLICATE of bug 297307

Status

Other Applications
DOM Inspector
--
major
VERIFIED DUPLICATE of bug 297307
13 years ago
10 years ago

People

(Reporter: philippe (part-time), Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050604 Firefox/1.0+ (PowerBook)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050604 Firefox/1.0+ (PowerBook)

since the landing of bug 295711, it is impossible to inspect the content of a
window (like a html document loaded in the front most window/tab). The URL of
the page doesn't appear in the file menu > Inspect a Window.
Opening the DomI through the keyboard short cut previously opened the DomI with
the html page in the front most window/tab. No longer.

Reproducible: Always

Steps to Reproduce:
1. load DomI (from menu or keyboard shortcut)
2. File menu > Inspect a window
3.

Actual Results:  
only chrome is accessible, not an html document.

Expected Results:  
1. if opened via the keyboard shortcut, open the DomI with the html doc from the
front most window/tab to inspect.
2. make that same url (html doc) available form the file menu.
Keywords: regression
Summary: [regression] Impossiibel to inspect the content of a window (html page). → Impossible to inspect the content of a window (html page).
I'm not sure if it is intended or not that you have to c&p the url into the DomI
locationbar ?

->NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
WFM on windows, maybe mac-only?
(Reporter)

Comment 3

13 years ago
Using this build
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050604
Firefox/1.0+ ID:2005060416

After launching Firefox, and loading an HTML doc, launching the DomI with the
keyboard shortcut displayed the document tree for the html doc (as expected).

However, after using Firefox for a while, using multiple tabs, normal browsing
session, and then attempting to inspect a window with the DomI (using the
keyboard shortcut) stopped working, the DomI simply opened a blank window.

In any case, the URL (in the frontmost window/tab) was not available for
inspection form the menu: file > Inspect a window. It used to be accessible from
there, I'm not sure however when that behaviour changed, as I rarely use this.

Comment 4

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050608 Firefox/1.0+

Recent Pacifica-trunk also shows just blank in the DOMInspector window on Win98SE.
This bug may affect not only Mac but also old Windows.

Comment 5

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050608
Firefox/1.0+

CTRL+SHIFT+I : works for me
(inspecting the inspector : document.defaultView.arguments[0] == "[object
XPCNativeWrapper [object HTMLDocument]]")

Tools -> DOM Inspector : fails
(inspecting the inspector : document.defaultView.arguments is empty)

Comment 6

13 years ago
The menu item used to call the InspectPage command:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/extensions/inspector/content/tasksOverlay.xul&rev=&cvsroot=/cvsroot&mark=42#40
The keyboard shortcut still does this.

The menu item now calls the Inspector command:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/inspector/resources/content/tasksOverlay-ff.xul&mark=40#38
OS: MacOS X → All
Hardware: Macintosh → All
Summary: Impossible to inspect the content of a window (html page). → Tools - DOM Inspector doesn't inspect the current page anymore, Ctrl+Shift+I works

*** This bug has been marked as a duplicate of 297307 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.