Closed Bug 296622 Opened 15 years ago Closed 15 years ago

subfolders with bookmarks are no longer accessible from the bookmarks bar

Categories

(Firefox :: Bookmarks & History, defect, P2, major)

PowerPC
macOS
defect

Tracking

()

RESOLVED FIXED
Firefox1.5

People

(Reporter: phiw2, Assigned: mano)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050604 Firefox/1.0+ (PowerBook)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050604 Firefox/1.0+ (PowerBook)

Since landing of bug 295711, when the bookmarks bar contains folders with sub
folders, those subfolders (and their content) are no longer accessible by
clicking on the parent folder in the bookmarks bar.

(those nested folders are coorectly listed in the bookmark manager, and are
accessible from the bookmark menu).

Reproducible: Always

Steps to Reproduce:
1. create bookmarks in nested folders in the bookmark bar folder
2. try accessisng those bookmarks
3.

Actual Results:  
Nothing, the nested folders do not show up as a pop up menu, or are not listed
as children of the parent folder.


Expected Results:  
Sow the nested folders
Keywords: regression
Depends on: 295711
Marked as depends, as per bug 295711 comment 17
cc'ing bsmedberg for the claimed regression.
Is this a mac-only regression? Seems to WFM on windows.
I don't see this on WinXP.
I think there is something different about the XUL templates that make the
bookmark menus/toolbar on mac, or there was a previous regression. I know this
bug is not about empty bookmark folders, but create an empty bookmark folder and
there is a behavior difference between win/mac on trunk (not 1.0):

1.0/win: subfolder has (Empty)
1.0/mac: subfolder has (Empty)

trunk/win: subfolder has (Empty)
trunk/mac: subfolder is missing

This seems suspicious to me, and I think fixing this problem might fix all of
this bug.
Almost certainly due to bug 260549: the #ifdef introduced by that bug should not
have removed the entire <menupopup>, just the context-menu attribute.
Assignee: dom-inspector → bugs.mano
Blocks: 260549
Status: UNCONFIRMED → NEW
Ever confirmed: true
Severity: normal → major
Status: NEW → ASSIGNED
Component: DOM Inspector → Bookmarks
Priority: -- → P2
Product: Other Applications → Firefox
Summary: subfolders with bookmarks ar no longer accessible from the bookmarks bar → subfolders with bookmarks are no longer accessible from the bookmarks bar
Target Milestone: --- → Firefox1.1
Version: unspecified → Trunk
QA Contact: timeless → bookmarks
Attached patch patchSplinter Review
Attachment #185677 - Flags: review?(benjamin)
Attachment #185677 - Flags: approval-aviary1.1a2?
Attachment #185677 - Flags: review?(benjamin)
Attachment #185677 - Flags: review+
Attachment #185677 - Flags: approval-aviary1.1a2?
Attachment #185677 - Flags: approval-aviary1.1a2+
Checking in browser-menubar.inc;
/cvsroot/mozilla/browser/base/content/browser-menubar.inc,v  <-- 
browser-menubar.inc
new revision: 1.51; previous revision: 1.50
done
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
This patch only partially fixes the problem, RSS feeds are still not visible
from the bookmarks bar. I'm seeing this in my own build pulled from CVS in the
last hour. Can anyone else verify this?
oops, that is fixed now too.
You need to log in before you can comment on or make changes to this bug.