Closed Bug 297142 Opened 15 years ago Closed 14 years ago

Moved profile folder shows profile in use message instead of cannot locate profile folder message

Categories

(Toolkit :: Startup and Profile System, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 278860

People

(Reporter: ispiked, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050608 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050608 Firefox/1.0+

If you move a profile to a different location and then try to open up
Thunderbird/Firefox again it will load the profile manager, but when you pick
the profile that you moved it says "Mozilla <Product> cannot use the profile
<profile name> because it is in use." 

Reproducible: Always

Steps to Reproduce:
1. Move your current folder to a new location. 
2. Start the program and choose to use that profile when the profile manager
come up (note: the profile comes up even if you choose to "not ask on start-up).

Actual Results:  
Alert box will pop up and say "Mozilla <Product> cannot use the profile <profile
name> because it is in use."

Expected Results:  
Alert box should say "Mozilla cannot use the profile <profile name> because the
directory containing the profile cannot be found. Please choose another profile
or create a new one".

I could see where this could become an issue if users are migrating profiles
between machines, etc., but I see it as pretty minor. Possible regression?
==> firefox
Component: Profile: Migration → Startup and Profile System
Product: Core → Firefox
QA Contact: profile-migration → startup
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Confirming. This is 100% reproducible. Still pretty minor, but I don't see why
we're giving the wrong error message here.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 278860 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.