If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Linkify (add links) bug count to buglist on keyword edit pages (editkeywords.cgi)

RESOLVED FIXED in Bugzilla 2.22

Status

()

Bugzilla
User Interface
P4
enhancement
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Tobias Sager, Assigned: Tobias Sager)

Tracking

2.19
Bugzilla 2.22
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050606 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050606 Firefox/1.0.4

The pages behind editkeywords.cgi (list and edit template) should linkify the
bug count to buglist as describekeywords.cgi does.

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

13 years ago
Created attachment 185776 [details] [diff] [review]
keywords-linkify.patch

Linkifies the bug counts on edit/list templates of editkeywords.cgi

Comment 2

13 years ago
Comment on attachment 185776 [details] [diff] [review]
keywords-linkify.patch

vladd, are you interested in reviewing this one?
Attachment #185776 - Flags: review?(vladd)

Comment 3

13 years ago
Comment on attachment 185776 [details] [diff] [review]
keywords-linkify.patch

This is a feature and it's unlikely to be commited in a feature-frozen branch
like 2.18.

Could you get the current CVS code and upload a patch based on it? I tried
applying the patch to the current CVS code but I got some failures. It's mainly
because we use now a table template to display the information.

The conversion to the tip code shouldn't take more than a few minutes. If you
upload the new version please request review on it :)
Attachment #185776 - Flags: review?(vladd) → review-
(Assignee)

Comment 4

13 years ago
It's in the works.
Do I need to filter the list for classifications (whatever that is)?
(Assignee)

Comment 5

13 years ago
Created attachment 185786 [details] [diff] [review]
keywords-linkify.patch-2

New patch for CVS tip.
(Didn't do any classifications filtering; believe these are for products only?)
(Assignee)

Updated

13 years ago
Attachment #185776 - Attachment is obsolete: true
Attachment #185786 - Flags: review?(vladd)

Comment 6

13 years ago
Comment on attachment 185786 [details] [diff] [review]
keywords-linkify.patch-2

Yeah.

There are 2 minor problems with this patch:

-> we have inconsistent behaviour for list.html and edit.html. In list.html we
linkify 0 bugs queries to the actual queries; in edit.html, we display "none"
instead.

-> An user could have editkeywords but it would be possible for him to lack the
credentials required to view certain bugs. In such situations, he would be able
to see that there is "1 bug" with the keyword set, but the query would return 0
bugs since he wouldn't be authorized to access it. By linkifying the number, we
give the impression that the query will display the number which is linkified;
this assertion will not always be true.

Otherwise looks good.
Attachment #185786 - Flags: review?(vladd) → review+

Updated

13 years ago
Assignee: myk → moixa
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Bugzilla 2.22

Updated

13 years ago
Status: NEW → ASSIGNED
Flags: approval?

Updated

13 years ago
Priority: -- → P4
Version: unspecified → 2.19
(Assignee)

Comment 7

13 years ago
(In reply to comment #6)
> There are 2 minor problems with this patch:

Do you want me to do anything about that?
I could change the patch to fix problem 1, but don't think I can do
anything concerning the second issue.

Comment 8

12 years ago
*** Bug 298231 has been marked as a duplicate of this bug. ***
Flags: approval? → approval+

Comment 9

12 years ago
Checking in template/en/default/admin/keywords/edit.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/keywords/edit.html.tmpl,v
 <--  edit.html.tmpl
new revision: 1.4; previous revision: 1.3
done
Checking in template/en/default/admin/keywords/list.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/keywords/list.html.tmpl,v
 <--  list.html.tmpl
new revision: 1.7; previous revision: 1.6
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.