Last Comment Bug 297540 - l10n CVS account request for Frisian language (fy-NL) for Wim <w.benes@gmail.com>
: l10n CVS account request for Frisian language (fy-NL) for Wim <w.benes@gmail....
Status: RESOLVED FIXED
form, ssh-key, voucher
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: x86 All
: -- normal (vote)
: ---
Assigned To: Dave Miller [:justdave] (justdave@bugzilla.org)
: Dave Miller [:justdave] (justdave@bugzilla.org)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-13 05:02 PDT by Wim
Modified: 2005-10-28 17:12 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
public key (294 bytes, text/plain)
2005-06-13 06:41 PDT, Wim
no flags Details
local files for Frisian Language (592.22 KB, application/zip)
2005-07-22 06:29 PDT, Wim
no flags Details
local files for Frisian Language (484.83 KB, application/zip)
2005-07-25 02:44 PDT, Wim
no flags Details

Description Wim 2005-06-13 05:02:14 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl-NL; rv:1.7.7) Gecko/20050414
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl-NL; rv:1.7.7) Gecko/20050414

the products I want to localize are Firefox and Thunderbird
the language + country code is fy-NL
my contact details (name + e-mail). Wim     w.benes@gmail.com

Reproducible: Always

Steps to Reproduce:
Comment 1 Tim Maks van den Broek [:mad_maks] 2005-06-13 05:14:19 PDT
1) Please attach or link your localization files in CVS structure for review.
2) Please attach your SSH public key
3) FAX the CVS contributor form and also mail it
Comment 2 Wim 2005-06-13 05:42:49 PDT
CVS contributor form has been faxed and original is in the mail.
Comment 3 Wim 2005-06-13 06:41:46 PDT
Created attachment 186097 [details]
public key
Comment 4 Axel Hecht 2005-07-01 05:31:23 PDT
Could we get a status update on this? We're going to branch 1.1 late next week and
would like to have at least a grip on the new locales for 1.1 by then.

Thanks
Comment 5 Wim 2005-07-04 02:22:10 PDT
(In reply to comment #4)
> Could we get a status update on this? We're going to branch 1.1 late next week and
> would like to have at least a grip on the new locales for 1.1 by then.
Not ready for new builds yet, it will take a few weeks at least, because we
start from scratch.

Kind regards,
Wim

Comment 6 Zibi Braniecki [:gandalf][:zibi] 2005-07-08 13:44:55 PDT
Can you give us any date when you want to be ready? Do you want to be ready for
1.1 or later?
Comment 7 Marcia Knous [:marcia - use ni] 2005-07-08 17:37:56 PDT
form received.
Comment 8 Wim 2005-07-10 23:51:46 PDT
(In reply to comment #6)
> Can you give us any date when you want to be ready? Do you want to be ready for
> 1.1 or later?

Pretty much later. 
It's a lot of work, there are not many helpers (yet) and summer holiday is coming.
Somewhere in autumn, but I hope earlier.
Comment 9 Wim 2005-07-22 06:29:45 PDT
Created attachment 190125 [details]
local files for Frisian Language

Included in the zipfile are the first translated files for the Frisian
language, as suggested by Mr. Maks.
Please do what you have to do with it, like putting them in CVS.

Thanks,
Wim
Comment 10 Tim Maks van den Broek [:mad_maks] 2005-07-22 07:16:53 PDT
Comment on attachment 190125 [details]
local files for Frisian Language

it is not a patch but a zip archive
Comment 11 Pavel Franc - Mozilla.cz 2005-07-22 07:57:18 PDT
> Included in the zipfile are the first translated files for the Frisian
> language, as suggested by Mr. Maks.

I did a quick check.
1) Please remove the hidden CVS directories from the nl files checkout,
2) use your own and unique UID in MOZ_LANGPACK_EID - not the one for nl,
3) don't replace ab-CD in firefox-l10n.js,
4) don't inlcude any extra files like *.~pr

Comment 12 Wim 2005-07-25 01:54:16 PDT
> 2) use your own and unique UID in MOZ_LANGPACK_EID - not the one for nl,
Where do I get this EID?
Comment 13 Pavel Franc - Mozilla.cz 2005-07-25 02:03:51 PDT
(In reply to comment #12)
> > 2) use your own and unique UID in MOZ_LANGPACK_EID - not the one for nl,
> Where do I get this EID?

http://kruithof.xs4all.nl/uuid/uuidgen or uuidgen utility on linux
Comment 14 Wim 2005-07-25 02:44:49 PDT
Created attachment 190391 [details]
local files for Frisian Language

I did the things requested by Pavel.

Again: it is not a patch but a zip archive

Thanks for reviewing.
Comment 15 Axel Hecht 2005-08-17 07:17:42 PDT
Open issues:

Searchplugins:
Please name the searchplugins appropriatly, like amazondotcom isn't actually 
.com in your locale.
I don't think you need dictionary.com, too. I'd suggest to use the frysian 
wikipedia instead.
Please make sure that your search plugins are encoded in MacRoman. That's the 
default, not utf8.
Falling back to nl for the other searches sounds reasonable.

Bookmarks: See http://wiki.mozilla.org/L10n:Firefox_Extras for the mozilla
links. Please adjust the wikipedia bookmark from nl to fy.
The mozbrowser.nl and http://www.mozilla-nl.org should go on the about pages,
if at all.

extra-jar.mn should just list the help-images. I'm not sure if you should check 
in the nl ones, though. And please use the format as in
http://lxr.mozilla.org/l10n/source/pl/browser/extra-jar.mn.

Those issues need to be addressed still, Wim, but I think we're ready to
set this live now.

Marcia, as far as I'm concerned, this account is ready to go.
Comment 16 Axel Hecht [:Pike] 2005-10-25 03:37:18 PDT
Marcia, I guess this should be turned over to justdave?
Comment 17 Marcia Knous [:marcia - use ni] 2005-10-25 16:43:26 PDT
reassigning to justdave, this one is ready to go.
Comment 18 Dave Miller [:justdave] (justdave@bugzilla.org) 2005-10-28 17:12:42 PDT
Account created.  Your CVSROOT should be:

   w.benes%gmail.com@cvs.mozilla.org:/l10n

Don't forget to set your CVS_RSH environment variable to 'ssh'

If you have any problems connecting, let me know.

Note You need to log in before you can comment on or make changes to this bug.