View Source cutoff when displaying a message with META line

VERIFIED WORKSFORME

Status

MailNews Core
Internationalization
P3
normal
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: rhp (gone), Assigned: jbetak@netscape.com (away - not reading bugmail))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I walked through this problem with Rick Gessner and it looks like we are having 
a problem with the META tag charset observer for the webshell. I will attach a 
message and all you have to do is View Source the message and you will see 
where we get cutoff, though I know that libmime is sending all of the data to 
layout.
(Reporter)

Comment 1

18 years ago
Created attachment 5936 [details]
View source this message and your display will get cutoff

Comment 2

18 years ago
This seems to be a 1-day regression.
View | Sourcing works on 1/28/2000 and 1/27/2000 Win builds
but not on 1/29/2000 Win build.

Thanks, rhp & rickg for this bug! So this was what it was in the
other bug, Bug 23931 on which you guys are working on.

Try this. 

1. First go visit Netscape Japan Page with today's build.
2. Now do View | Page Soucre
3. Confirm that it's not displayed in full.
4. Now turn on the Japanese Auto-Detection, i.e. View | Character Coding |
   Auto-Detect (Japanese).
5. Do View | Source again. This time you'll see the full page
   source displayed.
6. Now open the Mail test folder for Bug 23931. Display it
   and press reply/auto-quote. And viola! you see the whole thing
   quoted.
7. Go back to the Browser window, turn off the Auto-Detection
   and try the Bug 23931 test msg again. It gets cut off in
   the quoting.

I have had JPN auto-detect off because rhp's code to look into
the meta charset tag of an attachment has made it more or less unnecesary
to have it on for Mail. Though on the Browse side, it is more often tunred
on. 
The Browser problem is new today but it seems that the Mail quoting
probaly has had this problem for some time. Some recent change
exposed this.

I've tried the last 2-3 days build and they all work the same 
way with the tets msg for Bug 23931. The attachment gets
quoted in entirety if the JPN Auto-Detection is ON. 


   
   

Comment 3

18 years ago
Just to clarify the Browser side issue. I tried View | Source
of the Netscape Japan Home page which has a meta charset tag
with Auto-Detect (Japanese) ON and OFF. The full source display fails
on the 2/29/2000 build when the detection is OFF but not so
on earlier builds, 2/28 and 2/27. They dislay full page source
whether Auto-Detection is ON or OFF.

This may be in Cata's interest also. CC'ing him and a bunch of other
people.

Comment 4

18 years ago
One more clarification. When I said, 1-day regression,
I was referring to the Browser | View source problem only.
(Maybe I should file a separate bug on the Browser side?)
(Reporter)

Comment 5

18 years ago
You may want to have two separate bugs since I'm not sure the root of the 
problems are the same.

- rhp

Comment 6

18 years ago
Add jbetak and cata to the cc list since jbetak work on view source and cata 
work on charset menu recently which might relate to this issue.

Comment 7

18 years ago
sorry, I mislead the issue. jbetak and cata's work does not check in around that
time but much eariler.
add travis to the cc since he recently change a lot of thing in webshell which
might break this.

rhp- I still confused how to display your attachment, I try to view it but the
SeaMonkey said it do not understand the mime type rfc822 and ask me save it or
pick a app.... what should I do ?

Comment 8

18 years ago
There  is Mail View Source now.
You can place the msg in a local mail directory
and select to display it and then do "View | Page Source" from the menu
in Messenger.

Comment 9

18 years ago
Looks like viewing msgs in a local folder may be broken right now.
I was able to do view source on the test msg after I copied it from
a Local folder to an folder on an IMAP server. Then I see that 
your picture part is not displayed in view source. The display
ends at the beginning of that part with the meta charset tag line
as the last line.

Comment 10

18 years ago
I'm not going to file a bug on the Browser View Source problem mentioned above
because t does not occur with today's build. So this was a temporary condition.

Comment 11

18 years ago
Could you try this hack ?
Index: src/nsXMLDocument.cpp
===================================================================
RCS file: /m/pub/mozilla/layout/xml/document/src/nsXMLDocument.cpp,v
retrieving revision 1.54
diff -c -r1.54 nsXMLDocument.cpp
*** nsXMLDocument.cpp   2000/02/23 01:48:22     1.54
--- nsXMLDocument.cpp   2000/03/01 20:22:21
***************
*** 262,268 ****
    rv = aChannel->GetContentType(&aContentType);
    
    if (NS_SUCCEEDED(rv)) { 
!        if ( 0 == PL_strcmp(aContentType, "text/html")) {
                 bIsHTML = PR_TRUE;
         }
    }
--- 262,269 ----
    rv = aChannel->GetContentType(&aContentType);
    
    if (NS_SUCCEEDED(rv)) { 
!        if(( 0 == PL_strcmp(aContentType, "text/html")) ||
!           ( 0 == PL_strcmp(aContentType, "message/rfc822"))) {
                 bIsHTML = PR_TRUE;
         }
    }

I think this will fix it.
Status: NEW → ASSIGNED

Comment 12

18 years ago
reassign to jbetak. 
Assignee: ftang → jbetak
Status: ASSIGNED → NEW
(Reporter)

Comment 13

18 years ago
Hi Frank,
I applied this patch on Linux and it seems to be working fine. I'm not sure if 
this is just me or not, but I can't even get view source to work on web pages 
on Win32. I would go with the new fix if possible :-)

- rhp

- rhp
Rich,

the view source problem has been in the tree since Feb 22. Could you please 
elaborate on the Win32 pronlem some more, so I could address it better? I feel 
quite comfortable with Frank's change to the fix for 23083.

Thanks!
J.

P.S. Latest feedback on view source (23083):

------- Additional Comments From jshin@pantheon.yale.edu  2000-03-02 00:17 
I tried the newest nightly build(March 1st) and seems like
everything works fine. 
Status: NEW → ASSIGNED
(Reporter)

Comment 15

18 years ago
View source on the windows browser just crashes badly. Not sure if its just me 
or not?

- rhp
Depends on: 21909
Rich,

I´m tentatively closing this with "worksforme". I´ll leave the dependency to the
segfault crash 21909 for tracking purposes...Please feel free to reopen based on
your observations from M15.


Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 17

18 years ago
Yeah, from what I am seeing, I think this is mostly working, but there are some 
formatting issues that I am investigating.

- rhp

Comment 18

18 years ago
** Checked with 7/7/2000 Win32 build **

I have seen this function "work" and "not work" sometimes
but currently it seems to have stabilized. With the above build, 
I don't see a failure of View | Page Source in a variety of message
types including those with multiple attachments.
Marking it verified as fixed for now.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.