Closed Bug 297759 Opened 16 years ago Closed 13 years ago

"No chrome package registered for chrome://..." in Error Console

Categories

(Core :: Internationalization, defect)

defect
Not set
trivial

Tracking

()

VERIFIED FIXED
mozilla1.9beta3

People

(Reporter: bugzilla, Assigned: reed)

References

Details

(Whiteboard: [Steps: comment 7])

Attachments

(1 file, 2 obsolete files)

on a new nightly build and a clean profile I'm seeing:

No chrome package registered for chrome://navigator/locale/navigator.properties .
No chrome package registered for
chrome://navigator-platform/locale/navigator.properties .
Same here, I got 2 "No chrome package registered for
chrome://navigator/locale/navigator.properties ." and 1 "No chrome package
registered for
chrome://navigator-platform/locale/navigator.properties ." at every FF restart.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050715
Firefox/1.0+ ID:2005071506
Reporter,
Are you still seeing problems related to this bug?
Component: Build Config → General
QA Contact: build.config → general
(In reply to comment #2)
> Reporter,
> Are you still seeing problems related to this bug?

I just installed 1.5 on Linux, and receive the same messages in the js console. I did not clear my .mozilla folder (or any others). The messages do not appear when 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
> I did not clear my .mozilla folder (or any others). The messages do not appear
> when 

...woops. The messages do not appear when starting firefox with a url argument (firefox www.google.com).


I get/see 3 info notifications:

{
No chrome package registered for chrome://communicator/content/contentAreaUtils.js .

No chrome package registered for chrome://communicator/content/contentAreaDD.js .

No chrome package registered for chrome://communicator/content/findUtils.js .
}

in Error Console of Firefox 2.0b2 
rv:1.8.1b2 Gecko/20060825 BonEcho/2.0b2
I will try in Safe mode (I have not so far).
In safe mode with Firefox 2.0b2 
rv:1.8.1b2 Gecko/20060825 BonEcho/2.0b2

I get/see 2 info notifications:

{
No chrome package registered for chrome://communicator/content/utilityOverlay.xul .

No chrome package registered for chrome://communicator/content/tasksOverlay.xul .
}
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2pre) Gecko/2007110903 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

No bug.


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2pre) Gecko/2007110905 Minefield/3.0b2pre] (nightly) (W2Ksp4)

1. Display <about:config>.
r.
{{
No chrome package registered for chrome://navigator/locale/navigator.properties .

No chrome package registered for chrome://communicator-region/locale/region.properties .
}}

These two files are referenced from </modules/libpref/src/init/all.js> only.
Keywords: helpwanted
Whiteboard: [Steps: comment 7]
Version: unspecified → Trunk
Flags: blocking-firefox3?
Summary: "No chrome package registered" in console → "No chrome package registered for chrome://..." in Error Console
This is a very minor error that doesn't actually cause any problems and has been around for a long time. Why exactly should we be blocking the next Firefox release on it?
Severity: normal → trivial
"Why ... ?" Because the time has been long enough ?
Yet, I agree its minor and, if you don't care, I won't either.
Assignee: nobody → smontagu
Component: General → Internationalization
Flags: blocking-firefox3?
Keywords: helpwanted
Product: Firefox → Core
QA Contact: general → i18n
OS: Windows XP → All
Hardware: PC → All
Attached patch patch - v1 (obsolete) — Splinter Review
I think this will fix it.

* Remove the suite-only intl.content.langcode from js/tests/e4x/Regress/regress-308111.js and modules/libpref/src/init/all.js
* Rename chrome://navigator/locale/navigator.properties to chrome://global/locale/intl.properties
* Rename chrome://navigator-platform/locale/navigator.properties to chrome://global-platform/locale/intl.properties
Assignee: smontagu → reed
Status: NEW → ASSIGNED
Attachment #289175 - Flags: review?(smontagu)
Attachment #289175 - Flags: review?(bclary)
(In reply to comment #10)

> * Remove the suite-only intl.content.langcode from
> js/tests/e4x/Regress/regress-308111.js

This actually has nothing to do with the suite, but is instead an example xml document that was used to test e4x. You can remove the part about the test from your patch.

Attached patch patch - v1.1Splinter Review
Removed js test change.
Attachment #289175 - Attachment is obsolete: true
Attachment #289187 - Flags: review?(smontagu)
Attachment #289175 - Flags: review?(smontagu)
Attachment #289175 - Flags: review?(bclary)
Attachment #289187 - Flags: review?(smontagu) → review+
Comment on attachment 289187 [details] [diff] [review]
patch - v1.1

Get rid of some annoying errors that have bugged people for years by using the correct names for some intl files.
Attachment #289187 - Flags: approval1.9?
Comment on attachment 289187 [details] [diff] [review]
patch - v1.1

>+pref("general.useragent.locale", "chrome://global/locale/intl.properties");
Actually this is sorta wrong too... I don't know what Camino does, but this pref isn't localised in toolkit any more.
Comment on attachment 289187 [details] [diff] [review]
patch - v1.1

a=beltzner for 1.9
Attachment #289187 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
Checking in modules/libpref/src/init/all.js;
/cvsroot/mozilla/modules/libpref/src/init/all.js,v  <--  all.js
new revision: 3.715; previous revision: 3.714
done
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M11
I asked #camino, and they said they wouldn't be any less broken than they are now with this change. :)
Depends on: 409780
Per bug 409780 comment 4:
[
We should just remove intl.content.langcode completely, it was only introduced
for region packs, which we already killed in SeaMonkey.
]
Attachment #294674 - Flags: superreview?(neil)
Attachment #294674 - Flags: review?(neil)
Comment on attachment 294674 [details] [diff] [review]
(Bv1) Obsoleted code removal
[Moved to bug 409780]

Put this in another bug.
Attachment #294674 - Attachment is obsolete: true
Attachment #294674 - Flags: superreview?(neil)
Attachment #294674 - Flags: review?(neil)
(In reply to comment #19)
> (From update of attachment 294674 [details] [diff] [review])
> Put this in another bug.

I thought it better to have data and code removals in the same bug;
but moved to bug 409780.
Attachment #294674 - Attachment description: (Bv1) Obsoleted code removal → (Bv1) Obsoleted code removal [Moved to bug 409780]
V. Fixed,
between these two nightlies, per comment 7 steps:
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b3pre) Gecko/2007122405 Minefield/3.0b3pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b3pre) Gecko/2007122505 Minefield/3.0b3pre] (nightly) (W2Ksp4)
Status: RESOLVED → VERIFIED
Duplicate of this bug: 268607
You need to log in before you can comment on or make changes to this bug.