[gtk2]Mail crashes on attempt to send mail

RESOLVED WORKSFORME

Status

MailNews Core
Networking: SMTP
--
critical
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: William T Byron Jr., Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050615
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/2005061502

Since tindebox linux build 2005061518 you can not send mail. Crashes both mail
and browser as you hit quit. so far have not got gdb to catch stacktrace. As of
tinderbox build 2005061711 bug is still there.

Reproducible: Always

Steps to Reproduce:
1.open mail
2.compose mail
3.try to send mail

Actual Results:  
Crashes suite.

Expected Results:  
should send mail like allbuids 2005061502 back do.

There is bug 297942 that might be the same issue. There bromblem with Windows is
send mail later causes crash.

Updated

13 years ago
Keywords: crash
Version: unspecified → Trunk

Comment 1

13 years ago
worksforme with linux trunk 2005061705

can you submit a talkback report?  You can check them here:
http://talkback-public.mozilla.org/
Assignee: general → nobody
Component: General → Networking: SMTP
Product: Mozilla Application Suite → Core
QA Contact: general
(Reporter)

Comment 2

13 years ago
Here is the talkback ID # 6770113 I hope it helps. I something that points to
break here at line XXX to have a clue. Everything is in hex and I am just a
disabled auto tech that likes to mess around. The Talkback does not help me. I
wonder if it is a GTX2 problem? Are you using the lhasa-trunk? I am going to try
building a suite using the comet-trunk and see what happends.
(Reporter)

Comment 3

13 years ago
I hope this helps. I built the latest comet build it worked fine sent my self
three e-mails with no crashing. Go back to the latest lhasa build and crashes as
quick as I click the send button. I am been using the GTK2 builds since they
came out. I am a sucker for the better font rendering. Wired looking at the old
days of the suite.

Comment 4

13 years ago
ya, the hex stuff isn't useful  :(

was the 2005061502 build gtk2 or gtk1?
do you have any extensions installed or using a 3rd-party theme?
Summary: Mail crashes on attempt to send mail → [gtk2]Mail crashes on attempt to send mail
(Reporter)

Comment 5

13 years ago
No extensions or third part themes. The build 2005061502 is what I am using now.
It is a GTK2 build and works fine. I did not see the problem until 2005061518
tinderbox. For what it worth this afternoon I tried taking the mail.xpi from
2005061502 and swaped out the mail.xpi from 2005061702. It was a idea since I
thought it was a mail problem using the older builds files might work. Must been
major changes. When I built it and went to open mail all my mail was mising the
UI was there. I tried composing a letter and when I hit the send it still
crashed. So makes me feel that the problem is not in or all in the mail files. 
(Reporter)

Comment 6

13 years ago
I tried build 2005061719 after seeing all the changes including GTK2 and the
mail is now working. No problem sending mail. I'll try todays nightly build and
if it still works who ever is incharge of the core stmp mail can close this bug
as it looks like the regression has been fixed.
(Reporter)

Comment 7

13 years ago
Running todays nightly build with no problem with sending mail. Who ever is
incharge can close this out as what ever bug that showed up late 15th and 16th
has been corrected ont he GTK2 Build.

Comment 8

13 years ago
I don't know of any recent gtk2 changes that could have fixed this... it might
have actually been related to bug 297942 afterall...

anyway, resolving WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 9

12 years ago
It's back.  Compose/reply mail news message crashes on Send.  Leaves this message in the terminal:

Trying to position a sizeless window; caller should have called sizeToContent() or sizeTo().  See bug 75649.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051130 SeaMonkey/1.5a

--enable-application=suite --enable-calendar --disable-tests --enable-extensions=default,irc,tasks --without-system-nspr --without-system-jpeg --without-system-zlib --without-system-png --without-system-mng --disable-debug --enable-optimize=-Os --enable-crypto --enable-default-toolkit=gtk2 --enable-xft --disable-freetype2 --disable-xprint --with-pthreads --enable-svg

If this is wrong place, I'll report new or relocate as necessary.  I see lots of similar bugs but none more specific to the error message.
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.