Extension/Theme Manager support for DnD and keypress reordering

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
13 years ago
10 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 obsolete attachments)

I have DnD and keypress reordering in my tree and was waiting on bug 285584 to
land before submitting a patch. The keypress reordering is done via up/down
arrow along with shift up/down arrow for moving to top and bottom respectively.
Created attachment 186652 [details] [diff] [review]
patch
Assignee: nobody → rob_strong
Status: NEW → ASSIGNED
Attachment #186652 - Flags: review?(mconnor)
Comment on attachment 186652 [details] [diff] [review]
patch

I forgot to mention that the patch from bug 285584 removed the indenting I
added for one of the switch statements so this patch adds that back as well as
changes a toBeInstalled attribute that snuck in from Ben's tree to use the
opType attribute.
Doh! Forgot to say that the keypress reordering uses the control key... I
suspect the code will need to be changed to properly support other platforms
like Macs.
*** Bug 270309 has been marked as a duplicate of this bug. ***
Comment on attachment 186652 [details] [diff] [review]
patch

Better patch coming up
Attachment #186652 - Attachment is obsolete: true
Attachment #186652 - Flags: review?(mconnor)
Created attachment 186658 [details] [diff] [review]
patch

This should do it and the keys are
accel+shift+up arrow = move to top
accel+up arrow = move up
accel+down arrow = move down
accel+shift+down arrow = move to bottom
Attachment #186658 - Flags: review?(mconnor)
(In reply to comment #4)
> *** Bug 270309 has been marked as a duplicate of this bug. ***
This bug will not be adding the move top, move up, and move down menuitems to
the context menu of the theme manager as requested in that bug.
Attachment #186658 - Attachment is obsolete: true
Attachment #186658 - Flags: review?(mconnor)
Created attachment 186661 [details] [diff] [review]
patch

I removed everything not related to this bug out of the patch since I found a
couple of other minor regressions I am going to patch in another bug and
hopefully land that patch quickly.
Attachment #186661 - Flags: review?(mconnor)
Comment on attachment 186661 [details] [diff] [review]
patch

bit rotted
Attachment #186661 - Attachment is obsolete: true
Attachment #186661 - Flags: review?(mconnor)
We are going to support sorting ascending by name... for anyone that wants this it should be possible with an extension.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.