View Stored Passwords does nothing if passwords don't exist

VERIFIED FIXED in M15

Status

SeaMonkey
Passwords & Permissions
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: Stephen P. Morse)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 2000-03-01-08M15: NT4, Linux 6.0, Mac 8.5.1

Overview: When no passwords have been saved in the Wallet, selecting  to View 
Stored Passwords does nothing.

Steps to reproduce:
1. Open the Browser with a profile where no passwords have been saved
2. Select Tasks|My Wallet|Password Manager|View Stored Passwords

Actual Results: Nothing happens
Expected Results: If no passwords have been saved then a message should appear 
stating this fact. Similar to selecting "Change Master Password" when no master 
password exists.
dup of bug 28151.

*** This bug has been marked as a duplicate of 28151 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
I spoke with sairuh and it appears that this is a seperate issue since:

- My Wallet|Password Manager|View Stored Passwords, does nothing when no 
passwords have been saved. It should atleast display a message.
 - My Wallet|Password Manager|Change Master Password, displays a message "There 
is no master password to change".

morse - Should this be a seperate bug or a dupe?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

18 years ago
Things are getting confusing so let me straighten it up.  We currently have the 
following three bugs which relate to the case when no master password exists:

28151: change password gives an alert
29155: password-manager panel in prefs does not come up
29838: signon viewer does not come up

These are three distinct issues and we shouldn't be duping them.  I'm removing 
the dup indications.
Status: REOPENED → ASSIGNED
Target Milestone: M15
(Assignee)

Comment 4

18 years ago
Fix checked in.  Changes were in wallet.properties and singsign.cpp.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
verification blocked by bug 33516.
Depends on: 33516
removing dependency on bug 33516, since i can test this with a fresh profile on
mac.
No longer depends on: 33516
now get an Alert dialog saying, "No passwords have ever been saved." verified
fixed with opt comm bits:

linux 2000.03.30.09
macOS 2000.03.30.10
winNT 2000.03.30.09
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.