Password Manager's "show passwords' button logs out the internal key slot, forcing another master passwor request

RESOLVED DUPLICATE of bug 383229

Status

()

RESOLVED DUPLICATE of bug 383229
14 years ago
11 years ago

People

(Reporter: bugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050531 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050531 Firefox/1.0+

cached master password get lost under tools > options > privacy > passwords with
"view saved passwords" => "show passwords" => "cancel"

Reproducible: Always

Steps to Reproduce:
1. set a master password if not done yet
2. go to: Tools > Options > Privacy > Passwords
3. click: "view saved passwords", enter master password, click then "show passwords"

Actual Results:  
cached master password is lost

Expected Results:  
should stay cached if we click "cancel" and not "ok" on "show passwords"
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

14 years ago
Sorry, steps to reproduce above are a little bit unclear/incomplete
Here again:

1. set a master password if not done yet
2. go to: Tools > Options > Privacy > Passwords
3. click: "View Saved Passwords", enter your Master Password if not done on a
webpage earlier, and then click "Show Passwords"
4. click "cancel" (don't enter a password here)
5. close Password Manager
6. click on "View Saved Passwords" again or visit a Master-Password protected page

Actual Results:
Master Password isn't cached anymore (we have to re-enter it again)

Expected Results:
Master Password should stay cached if we click "cancel" and not "ok" on "show
passwords"

Can you confirm that?
Blocks: 382734
The problem is that the "show passwords" button logs the user out of the 
browser's PKCS#11 "internal key slot".  (The Master Password logs the user
into that slot.  The show passwords button logs the user out of that slot.)

The only reason that the user is prompted for the Master Password when he
clicks the "show passwords" button is that he has already been logged out
of that slot.  So, the real bug is that the user is logged out of the slot
when the "show passwords" button is clicked.  
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: cached master password get lost with "view saved passwords" => "show passwords" => "cancel" → Password Manager's "show passwords' button logs out the internal key slot, forcing another master passwor request
Bug 383229 explains the problem in some detail.  So I am marking this bug
as a duplicate of it.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383229
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.