Different Charset in Subject and Body confuses Thunderbiurd

RESOLVED DUPLICATE of bug 229399

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 229399
13 years ago
13 years ago

People

(Reporter: Florian Spisla, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Thunderbird/1.0.2 Mnenhy/0.7.2.0

The newsreader Dialog seems to use different charsets for encoding the subject
and the rest of an Usenet Posting:

[Message-ID: <3ht2m6Fip97lU1@individual.net>]
Subject: Re: Noch mehr Geld =?ISO-8859-15?Q?f=FCr_die_IV!_=3A-=28?=
Content-Type: text/plain; charset="utf-8"

When answering this with TB the result looks like this:
[Message-ID: <42b97da2_2@news.bluewin.ch>]
Subject: Re: Noch mehr Geld =?UTF-8?B?77+9?=
Content-Type: text/plain; charset=UTF-8; format=flowed

I've seen this more than once by now.

Reproducible: Always

Steps to Reproduce:
1. Find an posting with different charsets for subject and rest of posting
2. Answer to it

Actual Results:  
The special characters in the subject were "destroyed"

Expected Results:  
The character encoding should have been done correctly.

Comment 1

13 years ago
Related to/duplicate of Core bug 285053 -> Core bug 229399?

*** This bug has been marked as a duplicate of 229399 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.