Last Comment Bug 298750 - l10n CVS account request: Mongolian (mn-MN) - Natsagdorj Shagdar <natsagdorj@t-online.de>
: l10n CVS account request: Mongolian (mn-MN) - Natsagdorj Shagdar <natsagdorj@...
Status: RESOLVED FIXED
sshkey,voucher
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Dave Miller [:justdave] (justdave@bugzilla.org)
: Dave Miller [:justdave] (justdave@bugzilla.org)
Mentors:
Depends on:
Blocks: 289784
  Show dependency treegraph
 
Reported: 2005-06-25 01:39 PDT by Natsagdorj Shagdar
Modified: 2012-10-05 22:27 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
ssh public key (611 bytes, text/plain)
2005-06-25 01:46 PDT, Natsagdorj Shagdar
no flags Details
browser files to review (125.20 KB, application/x-zip-compressed)
2005-06-25 01:51 PDT, Natsagdorj Shagdar
no flags Details
tookit files to review (75.33 KB, application/x-zip-compressed)
2005-06-25 01:52 PDT, Natsagdorj Shagdar
no flags Details
Mn files in correct structure (265.14 KB, application/x-zip-compressed)
2005-06-30 02:04 PDT, Pavel Franc - Mozilla.cz
no flags Details
Translated MN files in correct structure (252.47 KB, application/x-zip-compressed)
2005-06-30 07:20 PDT, Natsagdorj Shagdar
no flags Details

Description Natsagdorj Shagdar 2005-06-25 01:39:55 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; mn-MN; rv:1.7.8) Gecko/20050511
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; mn-MN; rv:1.7.8) Gecko/20050511

l10n CVS account request

Reproducible: Always
Comment 1 Natsagdorj Shagdar 2005-06-25 01:46:52 PDT
Created attachment 187273 [details]
ssh public key
Comment 2 Natsagdorj Shagdar 2005-06-25 01:51:20 PDT
Created attachment 187274 [details]
browser files to review
Comment 3 Natsagdorj Shagdar 2005-06-25 01:52:29 PDT
Created attachment 187275 [details]
tookit files to review
Comment 4 Natsagdorj Shagdar 2005-06-27 10:29:06 PDT
Fax sent
Comment 5 Pavel Franc - Mozilla.cz 2005-06-30 02:04:10 PDT
Created attachment 187769 [details]
Mn files in correct structure

Your browser/toolkit files are for Firefox 1.1 but you put them in Firefox 1.0
structure. Therefore, you are missing files for dom, extension, netwerk,
other-licenses and security. I put your files in correct structure and use
english ones for missing directories. Please copy these files from your Firefox
1.0 (or Mozilla Suite) translation or translate them. Another issues are:

defines.inc
MOZ_LANGPACK_EID - generate your own GUID (uuidgen tool)
MOZ_LANGPACK_CREATOR - put down your team name (Mongolian Mozilla)

charset.mk 
WIN_INSTALLER_CHARSET - wouldn't be better RUSSIAN_CHARSET (CP1251)?
windows/install.it
CHARSET - wouldn't be better RUSSIAN_CHARSET (204)?

intl.properties
intl.accept_languages=mn, en-us, en
Comment 6 Natsagdorj Shagdar 2005-06-30 07:20:54 PDT
Created attachment 187803 [details]
Translated MN files in correct structure

I am not 100 percent sure that Russian_charset works. If it works, it is fine.
Because I never made installable build version of mozilla and firefox in
windows. 
Let us see what happens ;)  There is only 4 character difference between
russian and mongolian type ( It is about mongolian modern script, not mongolian
national script. The national script has the direction from top to down )

Thank you
Comment 7 Axel Hecht 2005-06-30 10:47:55 PDT
vouching. One nit I found is to uncomment
# #define MOZ_LANGPACK_CONTRIBUTORS <em:contributor>Natsagdorj
Shagdar</em:contributor>
like this:
#define MOZ_LANGPACK_CONTRIBUTORS <em:contributor>Natsagdorj
Shagdar</em:contributor>

Marcia, did you receive the form?
Comment 8 Natsagdorj Shagdar 2005-07-01 01:30:26 PDT
(In reply to comment #7)
> vouching. One nit I found is to uncomment
> # #define MOZ_LANGPACK_CONTRIBUTORS <em:contributor>Natsagdorj
> Shagdar</em:contributor>
> like this:
> #define MOZ_LANGPACK_CONTRIBUTORS <em:contributor>Natsagdorj
> Shagdar</em:contributor>
> 
> Marcia, did you receive the form?

thank you Axel.
Should I resend the corrected defines.inc file ? Or could you uncomment that line ?
Marcia, if you did not receive the form, should I send it again ? I sent it
before 3 days ago.
Thank you.
Comment 9 Axel Hecht 2005-07-01 01:39:38 PDT
No need to attach new files, just make sure that you fix it when you check in.
Comment 10 Marcia Knous [:marcia - use ni] 2005-07-01 17:33:32 PDT
Form received. Axel - is this one ready to activate?
Comment 11 Axel Hecht 2005-07-02 09:19:08 PDT
(In reply to comment #10)
> Form received. Axel - is this one ready to activate?

yes, please.
Comment 12 Marcia Knous [:marcia - use ni] 2005-07-05 17:40:00 PDT
Dave: This one is ready, please activate asap.
Comment 13 Dave Miller [:justdave] (justdave@bugzilla.org) 2005-07-06 17:00:24 PDT
Account has been created.  Your CVSROOT should be:

  natsagdorj%t-online.de@cvs.mozilla.org:/l10n

Don't forget to set your CVS_RSH environment variable to 'ssh'

Let me know if you have any problems connecting.
Comment 14 Chinzorig 2011-04-18 01:59:16 PDT
Hi I’m Mongolian , I want to update Mongolian language to firefox 4.0 version how to do that?
Comment 15 Channy Yun [:channy] 2012-07-16 07:50:06 PDT
(In reply to Chinzorig from comment #14)
> Hi I’m Mongolian , I want to update Mongolian language to firefox 4.0
> version how to do that?

Mongolian translation was paused after Firefox 9.0 beta. 
http://hg.mozilla.org/releases/l10n/mozilla-aurora/mn 

Are you interested in this job right now? If you're, please write down.

Note You need to log in before you can comment on or make changes to this bug.