Closed Bug 299019 Opened 16 years ago Closed 16 years ago

Switch win32 svg renderer backend to cairo

Categories

(Core :: SVG, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 310957

People

(Reporter: tor, Unassigned)

References

Details

Why?

# Less problems for the user, as they don't have to deal with downloading GDI+
if they're on an older system (pre-XP).
# Some bugs in GDI+ are unfixable (or at least, would take a lot of effort). For
example the spread method for radial gradients, bug 296411.
# Consistent behavior between platforms, up to the quality of the respective
cairo backends.
# Saving effort adding features for GDI+, which likely won't be used past 1.8.x.
The patch for <svg:textPath>, bug 282579, is an example of this.
Depends on: 299062
dup of bug 310957 ?
# bug 299062 already resolved ?

*** This bug has been marked as a duplicate of 310957 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.