Last Comment Bug 310957 - Switch win32 svg renderer from GDI+ to cairo
: Switch win32 svg renderer from GDI+ to cairo
Status: RESOLVED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: tor
:
: Gregory Szorc [:gps]
Mentors:
: 299019 (view as bug list)
Depends on: 310749
Blocks: 314060 314063
  Show dependency treegraph
 
Reported: 2005-10-03 11:34 PDT by tor
Modified: 2006-03-12 18:57 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
all platforms default to cairo (1015 bytes, patch)
2005-10-03 11:35 PDT, tor
benjamin: review+
mtschrep: approval1.8b5+
Details | Diff | Splinter Review

Description tor 2005-10-03 11:34:25 PDT
 
Comment 1 tor 2005-10-03 11:35:37 PDT
Created attachment 198332 [details] [diff] [review]
all platforms default to cairo
Comment 2 tor 2005-10-03 19:27:54 PDT
Comment on attachment 198332 [details] [diff] [review]
all platforms default to cairo

This allows SVG to work "out of the box" on pre-XP win32 machines and gives us
consistent behavior over all platforms.  We've had test builds out for a week
and have sorted out all the problems save for a printing font size issue that
is still being tracked down.  Some PR risk due to decreased performance of
cairo compared to GDI+ which was used in 1.5b1.
Comment 3 Mike Schroepfer 2005-10-03 22:25:46 PDT
Comment on attachment 198332 [details] [diff] [review]
all platforms default to cairo

Approving r.e. discussion on drivers email about migration to cairo for SVG.
Comment 4 tor 2005-10-03 22:54:55 PDT
Checked in on branch.  Leaving open for trunk checkin when we upgrade trunk
cairo to >= 1.0.2.
Comment 5 Peter van der Woude [:Peter6] 2005-10-04 01:25:34 PDT
I assume gksvggdiplus.dll can now be removed from the build (new bug needed ?)
Comment 6 Worcester12345 2005-10-05 13:56:32 PDT
(In reply to comment #5)
> I assume gksvggdiplus.dll can now be removed from the build (new bug needed ?)

I did a quick search on open bugs with GDI, and found 19 FWIW.
Comment 7 tor 2005-10-26 12:09:09 PDT
Checked in on trunk.
Comment 8 Christian :Biesinger (don't email me, ping me on IRC) 2006-01-27 15:04:20 PST
*** Bug 299019 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.