DOMFocusIn/DOMFocusOut not working properly

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
12 years ago
10 months ago

People

(Reporter: Stephen Pride, Assigned: Doron Rosenberg (IBM))

Tracking

({fixed1.8})

Trunk
fixed1.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050509 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050509 Firefox/1.0.4

The DOMFocusIn and DOMFocusOut events should be caught when a value is changed
for a form control that traps for them, but it doesn't.  See testcase.

Reproducible: Always
(Reporter)

Comment 1

12 years ago
Created attachment 187939 [details]
testcase

Comment 2

12 years ago
Actually, the 1.0 errata removes the mention of the DOM focus events:
http://www.w3.org/MarkUp/Forms/Group/Drafts/Sources/errata.html#E70e
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 3

12 years ago
OK. I missed something. It's not removed, it's just not specified in the value
change sequence. They should still be dispatched...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

12 years ago
Well, the right way to do this is to support DOMFocusIn and DOMFocusOut in the
core, which bryner says they will definitely take, but I'm sure it will be too
late for FF 1.5.  We could dispatch it ourselves as a stop gap until then, though.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

12 years ago
Blocks: 278448

Updated

12 years ago
Summary: DOMFocusIn/DOMFocuOut not working properly → DOMFocusIn/DOMFocusOut not working properly
(Assignee)

Comment 5

12 years ago
Created attachment 199973 [details] [diff] [review]
le patch
Assignee: aaronr → doronr
Status: NEW → ASSIGNED
Attachment #199973 - Flags: review?(aaronr)
(Assignee)

Comment 6

12 years ago
Created attachment 199974 [details] [diff] [review]
le patch
Attachment #199974 - Flags: review?(aaronr)
(Assignee)

Comment 7

12 years ago
Comment on attachment 199973 [details] [diff] [review]
le patch

double submit somehow, removing
Attachment #199973 - Attachment is obsolete: true
Attachment #199973 - Flags: review?(aaronr)

Comment 8

12 years ago
Comment on attachment 199974 [details] [diff] [review]
le patch

So far so good.  But looking at the spec looks like DOMFocusIn/Out needs to
happen for: input, secret, textarea, output, upload, trigger, range, submit,
select, select1, and group.  I don't know what we should do for output or
group, but the rest seem straight forward.
Attachment #199974 - Flags: review?(aaronr) → review-
(Assignee)

Comment 9

12 years ago
Created attachment 200115 [details] [diff] [review]
better patch

For a full appearance select, this is hard to implement, so XXX: for now.
Attachment #199974 - Attachment is obsolete: true
Attachment #200115 - Flags: review?(aaronr)
(Assignee)

Updated

12 years ago
Attachment #200115 - Attachment is obsolete: true
Attachment #200115 - Flags: review?(aaronr)
(Assignee)

Comment 10

12 years ago
Created attachment 200143 [details] [diff] [review]
even better patch
Attachment #200143 - Flags: review?(aaronr)

Comment 11

12 years ago
Comment on attachment 200143 [details] [diff] [review]
even better patch

Looks good.  Please open a bug for range and upload to support these (or leave
this bug open to account for them).
Attachment #200143 - Flags: review?(aaronr) → review+
(Assignee)

Updated

12 years ago
Attachment #200143 - Flags: review?(smaug)

Comment 12

12 years ago
Comment on attachment 200143 [details] [diff] [review]
even better patch

I guess this is ok for now.
Attachment #200143 - Flags: review?(smaug) → review+
(Assignee)

Comment 13

12 years ago
Checked into trunk. Do we want this on branch?

Comment 14

12 years ago
Since bug 275453 was fixed then patch should be updated. Now 'upload' element calls removed dispatchDOMActivate() method.
(Assignee)

Comment 15

12 years ago
checked into branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.