[l10n] "Add to Address Book" not localized.

RESOLVED FIXED

Status

Camino Graveyard
Translations
--
trivial
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Markus Amalthea Magnuson, Assigned: Usul)

Tracking

({fixed1.8})

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050620 Camino/0.9a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050620 Camino/0.9a1

It seems like the context meny choice "Add to Address Book" (on mailto-links)
isn't localized, even though I've translated it. When I check that CM in
Interface Builder it is translated, but not when I run Camino.

Reproducible: Always

Steps to Reproduce:
Any reason this is not confirmed?  Is this just another string missing?
Summary: "Add to Address Book" not localized. → [[l10n] "Add to Address Book" not localized.

Comment 2

13 years ago
It looks like the item title is set in code, via a string in Localized.strings
(though I'm not sure why, if it's in a nib).

Does adding

"Add to Address Book" = "Your localized string";

to your language's Localized.strings file work?
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [[l10n] "Add to Address Book" not localized. → [l10n] "Add to Address Book" not localized.
Markus, does Wevah's suggestion work?
(In reply to comment #2)
> It looks like the item title is set in code, via a string in Localized.strings
> (though I'm not sure why, if it's in a nib).

Wevah, is it done that way because it switches to "Open %@ in Address Book" when
clicking on the address of someone already in your Address Book (note that
string is present in Localized.strings)?

Comment 5

13 years ago
That's probably why.

Comment 6

13 years ago
Confirmed Wevah's expectations. Adding the string to Localizable.strings solves
the problem.
Ex. 
/* mailto: link menu options */
"Open %@ in Address Book" = "Apri %@ in Rubrica Indirizzi";
"Add to Address Book" = "Aggiungi a Rubrica Indirizzi";

Can somebody check-in an updated Localizable.strings?
Mike/Simon, here's an updated Localizable.strings file for checkin to fix this.
Comment on attachment 197241 [details]
Updated localizable.strings for checkin

Reminder that this is waiting for checkin :-)
Attachment #197241 - Attachment mime type: application/octet-stream → text/plain; charset=UTF-16

Comment 10

13 years ago
Checked in, trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.