Last Comment Bug 300754 - [sw-TZ] Kiswahili Firefox localization (Kilinux Team)
: [sw-TZ] Kiswahili Firefox localization (Kilinux Team)
Status: RESOLVED INCOMPLETE
:
Product: Mozilla Localizations
Classification: Client Software
Component: Registration & Management (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Localization Registration Bugs
:
Mentors:
www.kilinux.udsm.ac.tz
Depends on:
Blocks: 293722
  Show dependency treegraph
 
Reported: 2005-07-14 04:00 PDT by kilinux-team
Modified: 2010-04-09 01:55 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
ssh-public-key (600 bytes, text/plain)
2005-11-08 03:51 PST, kilinux-team
no flags Details
sw-TZ.xpi (97.98 KB, application/x-xpinstall)
2005-12-12 23:59 PST, kilinux-team
no flags Details
sw-TZ Firefox l10n package (411.75 KB, application/octet-stream)
2009-03-04 09:28 PST, Zibi Braniecki [:gandalf][:zibi]
no flags Details
comparsion between en-US (96.38 KB, text/plain)
2009-03-04 09:34 PST, Zibi Braniecki [:gandalf][:zibi]
no flags Details
another form of a diff (44.87 KB, text/plain)
2009-03-04 09:36 PST, Zibi Braniecki [:gandalf][:zibi]
no flags Details
sw-TZ fx 3.1 bundle (324.89 KB, application/octet-stream)
2009-03-04 10:13 PST, Zibi Braniecki [:gandalf][:zibi]
no flags Details
Firefox 3.1 half baked up to date localization (472.87 KB, application/x-zip-compressed)
2009-03-12 11:49 PDT, Zibi Braniecki [:gandalf][:zibi]
no flags Details
sw-TZ updated to latest Fx3.5 (502.74 KB, application/octet-stream)
2009-04-06 16:26 PDT, Zibi Braniecki [:gandalf][:zibi]
no flags Details
obsolete entities (5.17 KB, text/plain)
2009-04-06 16:29 PDT, Zibi Braniecki [:gandalf][:zibi]
no flags Details
sw-TZ Files of Fx 3.5 by 20090410 (143.84 KB, application/x-bzip)
2009-04-12 04:49 PDT, Emanuel Feruzi
no flags Details
sw-TZ Files (155.44 KB, application/octet-stream)
2009-04-12 15:08 PDT, Emanuel Feruzi
no flags Details
sw-TZ-20090413-RC1 (151.63 KB, application/x-bzip)
2009-04-13 11:50 PDT, Emanuel Feruzi
no flags Details
RC1 - Review 1 (150.87 KB, application/x-bzip)
2009-04-20 01:24 PDT, Emanuel Feruzi
no flags Details
sw-TZ RC2 (120.31 KB, application/x-xpinstall)
2009-06-11 02:33 PDT, Emanuel Feruzi
no flags Details

Description kilinux-team 2005-07-14 04:00:03 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225


Dear Sir

Open swahili localization project requests access to cvs for localizing
Firefox 1.0.3.

Product for localizing: Firefox 1.0.3
Language: Kiswahili (sw)
Country: Tanzania (TZ)
Contacts: Dr H.M. Twaakyondo
          Project Coordinator

E-mail: kilinux-team@cs.udsm.ac.tz
Web-page: www.kilinux.udsm.ac.tz


Reproducible: Always
Comment 1 Pavel Franc - Mozilla.cz 2005-07-15 09:51:38 PDT
There is already an open bug 293722 for registration of Swahili (sw-TZ)
localization. Please add the above information about your team to that bug and
contact its reporter - Ali Ayub Kalufya about the status of his localization. It
would be unpleasant to have two localization teams working on Swahili Firefox.

I was also contacted by Jimmy T. Mbelwa from Kilinux Localization Project, who
asked me about the Swahili installer (I hope he is from your team) and I sent
him a some instructions what to do to get your files into CVS.
Comment 2 Marcia Knous [:marcia - use ni] 2005-08-11 18:15:32 PDT
If this is an open bug for cvs access, need to get the CVS form
(www.mozilla.org/hacking/form.html) and a voucher to post in the bug.
Comment 3 Axel Hecht 2005-08-11 23:37:20 PDT
We need to fix the registration bug first. We didn't make progress on the 
different teams yet.
Comment 4 kilinux-team 2005-11-06 22:37:41 PST
We have sent the contributor form to the following addresses
1. marcia@mozilla.org
2. Marcia Knous
   Mozilla Corporation
   1981 Landings Drive. Building K
   Mountain View, Califonia 94043
   USA

Comment 5 kilinux-team 2005-11-08 03:51:44 PST
Created attachment 202231 [details]
ssh-public-key

Find the attached file for the ssh-public-key 
regards,
kilinux
Comment 6 Marcia Knous [:marcia - use ni] 2005-11-16 11:33:04 PST
CVS form received.
Comment 7 kilinux-team 2005-12-12 23:59:34 PST
Created attachment 205702 [details]
sw-TZ.xpi

Swahili xpi file is attached
Comment 8 kilinux-team 2006-01-03 22:23:45 PST
We are remind you about cvs account.We are waiting more from you.
Comment 9 Marcia Knous [:marcia - use ni] 2006-01-11 10:46:09 PST
Axel: Let me know if this one is ready to go.
Comment 10 Marcia Knous [:marcia - use ni] 2006-02-06 10:29:03 PST
Dr H.M. Twaakyondo: I am waitng for someone to vouch for you in this bug, as well as the approval from Axel to create your CVS account.  Also, has the issue raised in Comment 1 been resolved?

I have received your CVS form.
Comment 11 kilinux-team 2006-02-15 22:28:09 PST
The issued raised in comment 1 had been resolved. We agree with Mr. Ali Ayub Kalufya that our project team will take over.
The Project Team members are:
1. Dr H.M. Twaakyondo
2. Dr. Seleman S. Sewangi
3. Prof ZSM Mochiwa
4. Dr. Peter Mtesigwa
5. Dr. John G. Kiango
6. Dr. George Mrikaria
7. Ulrick Mkenda
8. Mturi Elias
9. Kennedy F. Mwakisole
10. Jimmy T. Mbelwa
11. James Chambua
12. Abdulla F. Ally
13. Prof. Iddi S.N. Mkilaha
Comment 12 kilinux-team 2006-03-14 23:40:04 PST
We need to know the progress for creating the cvs account for kilinux team. We are still waiting to get that account
Comment 13 Axel Hecht [:Pike] 2006-03-16 04:37:59 PST
For which version is the attached xpi?

What we really want to see is a zip containing the source to be used for a 
1.5.0.x localization.
http://wiki.mozilla.org/Draft:L10n:Creating_a_new_Localization has some tips,
though that doc is still in draft, sadly.
Comment 14 kilinux-team 2006-03-20 03:30:33 PST
The xpi attached is firefox-1.0.3

We hope we will get the cvs account soon
Comment 15 Axel Hecht [:Pike] 2006-03-20 04:03:58 PST
Sorry for getting back to this so late. I'm even more sorry to tell you that we
don't accept new localizations on the 1.0.x branch anymore. That release is in
maintainance mode, we want new users to use 1.5.x.

I can safely say though that even back in december, we wouldn't have accepted it.

We'd appreciate if you could adapt this work to match the 1.5.0.x releases, and
provide a source localization. That would be the MOZILLA_1_8_0_BRANCH in CVS.
Some (growing) documentation is available on 
http://wiki.mozilla.org/Draft:L10n:Creating_a_new_Localization
Comment 16 Marcia Knous [:marcia - use ni] 2006-07-03 13:11:03 PDT
Do we want to keep this bug open - are there plans to make this a 1.5 product? Please advise so we can update the bug.  Thanks.

(In reply to comment #15)
> Sorry for getting back to this so late. I'm even more sorry to tell you that we
> don't accept new localizations on the 1.0.x branch anymore. That release is in
> maintainance mode, we want new users to use 1.5.x.
> 
> I can safely say though that even back in december, we wouldn't have accepted
> it.
> 
> We'd appreciate if you could adapt this work to match the 1.5.0.x releases, and
> provide a source localization. That would be the MOZILLA_1_8_0_BRANCH in CVS.
> Some (growing) documentation is available on 
> http://wiki.mozilla.org/Draft:L10n:Creating_a_new_Localization
> 

Comment 17 kilinux-team 2006-07-06 00:49:45 PDT
Yes.We are plan to make this  a 1.5 product.So keep this bug open
Comment 18 kilinux-team 2006-08-10 02:07:34 PDT
We are ready for the Firefox 1.5.0.4. Pls we need the cvs account and registration for it as soon as possible
Comment 19 Marcia Knous [:marcia - use ni] 2006-08-10 11:49:06 PDT
Axel: Okay, based on the last comment, is this one one ready to go?
Comment 20 kilinux-team 2006-08-15 00:34:06 PDT
Yes.
Comment 21 kilinux-team 2006-09-06 23:59:27 PDT
How far have you reached? We are ready for the Firefox 1.5.0.4. Pls we need the cvs account and registration for it as soon as possible.
We need it soon as possible.
Comment 22 Axel Hecht [:Pike] 2006-10-25 08:47:47 PDT
So, now we're at the point where we won't take new locales on the 1.5 branch anymore.

Please take a look at http://developer.mozilla.org/en/docs/Create_a_new_localization for information on the right format of the submitted localization for review.

I took a look at http://www.google.com/search?q=cache:Af0dxz--TmMJ:www.kilinux.udsm.ac.tz&hl=de&lr=&strip=1 (the site itself is currently down) and saw that this has an announcement for a 1.0.3 version of Firefox as of September this year.
I'm CCing Window Snyder, she offered help Kiswahili, and as she's working on security in Firefox, she'd have lots to say on making the version 1.0.3 publically available. Though maybe not in public.
Comment 23 kilinux-team 2006-11-23 23:29:21 PST
Since it is not possible to take a new locales on the 1.5 branch, we need to use this bug for 2.0  branch to get CVS account and file registration.
Comment 24 kilinux-team 2006-12-18 04:50:27 PST
We still waiting for you, we need the cvs account and registration for kiswahili using this bug based on 2.0 branch. We need it so that we can start localization
Comment 25 Axel Hecht [:Pike] 2006-12-18 05:16:26 PST
I'm still waiting on some internal feedback on some things before I start looking at new locales again.

I expect that to be done early next year.

Sorry for the delay.
Comment 26 kilinux-team 2007-04-04 00:06:59 PDT
How far have you reached?We are still waiting for you. We need to start as soon as possible
Comment 27 kilinux-team 2007-07-12 22:28:40 PDT
I would like to know the stastus of cvs account and registration for
kiswahili using this bug based on 2.0 branch.We waiting almost half of the year.We need urgently so that we casn proceed
Comment 28 kilinux-team 2007-09-04 01:53:46 PDT
Hi.We are still waiting to get a new locales.How far have you reached?We need to localize firefox based on 2.0 branch.We need to know the status of cvs account and registration for swahili
Comment 29 kilinux-team 2007-09-26 01:31:13 PDT
Hi.How far have you reached have you reached? We are still waitnig for you almost the 6 months now. We nedd to need to localize firefox based on 2.9 branch.Also we need to know the status of cvs account and registration for swahili
Comment 30 Gervase Markham [:gerv] 2007-09-27 12:06:23 PDT
Hi. In order to start translating, you need to read this wiki page and follow the procedures there:
http://wiki.mozilla.org/L10n:Starting_a_localization

Create yourself a wiki page for your localisation, which registers you as the team for that language. Then, follow the instructions on the wiki to produce a language pack you can distribute through addons.mozilla.org. Once you have reached that stage, we can consider your pack for official status - although I should warn you that this is a separate process with its own complexities. (It is at this stage that CVS account requests would be needed.) Still, the community will still be able to get your pack from addons.mozilla.org in the meantime.

If you have read carefully and find the documentation isn't good enough in any way, please let us know and we will improve it.

Gerv
Comment 31 Reed Loden [:reed] (use needinfo?) 2008-06-15 23:06:32 PDT
Due to a recent overhaul of the committer's agreement, we are requiring new forms be sent for accounts that have yet to be created, even if you have already filled out and submitted the old CVS Contributor Form. Please download the form at http://www.mozilla.org/hacking/committer/committers-agreement.pdf and submit it according to the directions specified at http://www.mozilla.org/hacking/notification/. We apologize for this necessary inconvenience. If you have any questions, feel free to ask. Thanks!
Comment 32 kilinux-team 2008-09-01 01:17:34 PDT
Dear Sir,
My name is Kennedy Frank, can you give me more information about the purpose of this form, Kilinux project team under the Coordinator Dr. H.M. Twaakyondo give me a task to make follow up on the registration of Kiswahili (sw-TZ) localization

Regards
/Kenny
Comment 33 Gervase Markham [:gerv] 2008-09-01 04:50:07 PDT
Kenny,

You do not need our permission to start localization work. Please see
http://wiki.mozilla.org/L10n:Starting_a_localization
for details of the process, which includes details of how to register yourselves. Please let us know if you have any questions about that page.

Gerv
Comment 34 Seth Bindernagel 2008-09-02 16:42:13 PDT
And, to support Gerv's point above, please email us if you need any help.  Did Gerv's link answer your question above about the importance of the registration process?
Comment 35 kilinux-team 2008-09-03 00:44:32 PDT
Hi, i hope you have read my messages so we are supposed to do right now so that we can get a CVS account?, please we need to proceed with localization of firefox even though we have not yet started localizing the latest version of firefox but you can give us a way on how to go about because the team is ready to start localizing the latest version of firefox.
regards
:/Kenny
Comment 36 Gervase Markham [:gerv] 2008-09-03 02:40:14 PDT
Kenny,

Both here and in private mail I have sent you instructions about what to do next. Please do those things :-)

Here they are again:

The list of things you need to do is here:
https://wiki.mozilla.org/L10n:Starting_a_localization

For example, the first thing you need to do is:

"Add yourself to a L10n:Teams wiki page that identifies you and what
you're working on so people can find you."

That basically means you are registered.

If you have already done the localization work for Firefox 3, then the
next step is:

"To make your work available for users to download and test, create a
language pack which can be hosted on AMO."

And so on. Please let me know if that page is not clear, and I will make
it more clear. If you need help with the actual localization process, then that page also offers guidance on where to find it. 

I hope that is helpful :-)

Gerv
Comment 37 Axel Hecht [:Pike] 2008-09-08 02:57:24 PDT
This bug isn't really about cvs access at this time, making this a registration request.

Some clarifications:

Registration is not required to work on a translation, but I strongly suggest creating a wiki page to be listed at https://wiki.mozilla.org/L10n:Teams, which is what the previous document pointers aim at.

Registration is based on a technical review of a submitted source.

Granting write access to our repositories is done based on the review and registration, and is done per individual. We don't grant access to groups.

On a related note, for the language code, is "sw" precise enough, or is "-TZ" a required specification of a dialect of Kiswahili?
Comment 38 Axel Hecht [:Pike] 2008-09-09 02:16:42 PDT
Would whoever is hiding behind that kilinux alias please stop messing with the bug subjects and such? You're not constructive.
Comment 39 Ali Ayub Kalufya 2008-09-09 02:39:57 PDT
I suggest that individual members of the Kilinux team register themselves into this ongoing effort and start contributing to work already done. We need to see outputs and not continued e-mail exchanges. In case anybody fails to get registered, the person should contact the project lead Dr. Twaakyondo and see that sorted out. We started this as an open-to-all-interested effort and I believe it is best kept that way.
Comment 40 Seth Bindernagel 2008-09-10 08:27:37 PDT
To contribute to Axel's, Gerv's, and Ali's comments above, I will offer one other option:

If anything is confusing to this point, let's have a chat on IRC.  I can make myself available at anytime that is convenient for you to answer basic questions about our localization process.  We can discuss the actual localization process of the Firefox browser (and other Mozilla projects, if you're interested), the registration process, and other topics related to building a thriving and sustainable community.  Would the Kiswahili team be interested in that?  If so, let's start a live chat on IRC or some other method (Skype or Instant Message) so we can have a real-time exchange to answer questions.

For IRC, my IRC nickname on the irc.mozilla.org server is "sethb".

Hope you are all well and hope to connect.  

Best regards,

sethb
Comment 41 Zibi Braniecki [:gandalf][:zibi] 2009-03-04 09:28:16 PST
Created attachment 365453 [details]
sw-TZ Firefox l10n package

attaching latest package sent by Kenny
Comment 42 Zibi Braniecki [:gandalf][:zibi] 2009-03-04 09:34:01 PST
Created attachment 365457 [details]
comparsion between en-US 

first version of a diff between latest en-US Firefox 3.1 and sw-TZ package (after morphing it into something compareable)
Comment 43 Zibi Braniecki [:gandalf][:zibi] 2009-03-04 09:36:19 PST
Created attachment 365460 [details]
another form of a diff

another form of a diff between 3.1 Firefox and sw-TZ localization
Comment 44 Zibi Braniecki [:gandalf][:zibi] 2009-03-04 10:13:43 PST
Created attachment 365469 [details]
sw-TZ fx 3.1 bundle

attaching a bundle with structure matching our source one.
Comment 45 Zibi Braniecki [:gandalf][:zibi] 2009-03-12 11:49:23 PDT
Created attachment 367085 [details]
Firefox 3.1 half baked up to date localization

This package contains full localization of en-US for 3.1 merged with sw-TZ localization. You should start from here localizing en-US strings.
Comment 46 kilinux-team 2009-03-13 00:53:43 PDT
(In reply to comment #45)
> Created an attachment (id=367085) [details]
> Firefox 3.1 half baked up to date localization
> 
> This package contains full localization of en-US for 3.1 merged with sw-TZ
> localization. You should start from here localizing en-US strings.

Thank you for the package. If we convert .dtd and .properties files into .po files and translate them, will it be possible for you to help us on creating sw-TZ for 3.1
Comment 47 Zibi Braniecki [:gandalf][:zibi] 2009-03-13 04:08:40 PDT
(In reply to comment #46)
> Thank you for the package. If we convert .dtd and .properties files into .po
> files and translate them, will it be possible for you to help us on creating
> sw-TZ for 3.1

If you keep the structure of the files and keep the PO follow the gettext syntax then I see no problem to convert it back at the end.

What you were sending me before was much different (with msgid and msgstr being both value, and id hidden in a comment preceding the entity).

So it's up to you, but the more complex it'll be for me to convert it back the longer it'll take.
Comment 48 Seth Bindernagel 2009-03-13 12:04:39 PDT
(In reply to comment #47)
> (In reply to comment #46)
> > Thank you for the package. If we convert .dtd and .properties files into .po
> > files and translate them, will it be possible for you to help us on creating
> > sw-TZ for 3.1
> 
> If you keep the structure of the files and keep the PO follow the gettext
> syntax then I see no problem to convert it back at the end.

Let me reiterate Zbigniew's (irc Gandalf) point:  If you choose to use PO file structure, then please follow the gettext syntax.  We can definitely help, but it would be most helpful for you to follow a consistent format throughout all the work.  Othewise, Gandalf and you will have a challenging time finding out what exactly is incorrect.

Seem clear?  Definitely err on the side of precision and consistency.  That will be most helpful.  :-)  Feel free  to continue to ask questions in this bug.
Comment 49 kilinux-team 2009-03-16 00:52:00 PDT
Yes i followed your advice and so far we have created PO file which follow gettext syntax. I want know something; Did you use sw-TZ localization i sent to you to merge with en-US for fx 3.1?
Comment 50 kilinux-team 2009-03-16 00:54:57 PDT
Zbigniew help on Comment #49
Comment 51 Zibi Braniecki [:gandalf][:zibi] 2009-03-16 14:40:15 PDT
Yes, I based on what I received.
Comment 52 kilinux-team 2009-03-17 22:43:23 PDT
Thank you Zbigniew. Have a look at the following problem:
If i use moz2po to convert sw-TZ (obtained after unzip sw-TZ-fx-3.1-full.zip) to po files (sw-Po), 271 files are processed as shown below

[kenfra@jambo sw-TZ]$ ls
sw-TZ  sw-TZ-fx-3.1-full.zip
[kenfra@jambo sw-TZ]$ moz2po -i sw-TZ -o sw-Po

moz2po: warning: Output directory does not exist. Attempting to create
processing 271 files...
[###########################################] 100%


And if i try to convert back using po2moz i.e

[kenfra@jambo sw-TZ]$ po2moz -i sw-Po/ -o sw-TZ-fx-3.1-new

only 270 files are processed

po2moz: warning: Output directory does not exist. Attempting to create
processing 270 files...
[###########################################] 100%

Can you help me to solve this before starting translation
Comment 53 Zibi Braniecki [:gandalf][:zibi] 2009-03-18 03:49:44 PDT
Unfortunately, I'm not familiar with the internals of moz2po/po2moz scripts. We do not support them either.

Would you consider using one of the community webtools instead (like https://l10n.mozilla.org/narro) ?
Comment 54 Friedel Wolff 2009-03-18 08:34:33 PDT
(In reply to comment #52)
Feel free to contact us at the Translate project for help with po2moz and moz2po. The mailing list and IRC channel can be obtained from http://translate.sourceforge.net/

The issue is most likely that there is a file without any translatable content for which a POT/PO file is not generated. In recent files for Firefox, it could be this file, for example:
extensions/reporter/chrome/reporterOverlay.properties

It is a pity that non-translatable files are given to translators to translate/not translate, but you can handle this by copying that file from the en-US sources to your translation to have it in the sw directory.

Hope that helps.
Comment 55 Dwayne Bailey 2009-03-18 09:12:52 PDT
(In reply to comment #53)
> Unfortunately, I'm not familiar with the internals of moz2po/po2moz scripts. We
> do not support them either.
> 
> Would you consider using one of the community webtools instead (like
> https://l10n.mozilla.org/narro) ?

Well we, Translate.org.za, do support them and I guess we are part of the community.  Gandalf I'd be happy to give you training on how the tools work.

Here is a summary of what to do and with a good set of PO files.  You'll see that its easy to recover from this pre 2 translation.

1) moz2po -P en-US pot / download from http://l10n.mozilla.org/pootle/pot/firefox-3.1b3-20090109.tar.bz2

2) pomigrate2 old-sw new-sw pot / potpot -t old-sw pot new-sw
# Translate the resultant PO files in your PO tools

3) po2moz -t en-US sw-po-file sw

At the final step you'll get a set of .dtd and .properties files like those Gandalf supplied.

The benefits of staying on PO is that you will always know the state of your translations i.e. what is translate what is fuzzy..  You can use your PO tools and moz2po is all you need to get the files ready.
Comment 56 kilinux-team 2009-03-19 00:11:46 PDT
(In reply to comment #54)
Thank you for your help and the file you indicated (extensions/reporter/chrome/reporterOverlay.properties)is the missing one the rest are fine. We will copy it after convert back .po files to .dtd and .properties. Hope it will fine
Comment 57 Zibi Braniecki [:gandalf][:zibi] 2009-04-06 16:26:50 PDT
Created attachment 371338 [details]
sw-TZ updated to latest Fx3.5

I'm attaching the latest localization merge. It contains all entities required for Firefox 3.5 at the moment.

Please use it as a base for your localization.

Two notes:
1) You still have a lot of entities that are marked as FUZZY because they were modified between Firefox 1.0 (which we based on) and Firefox 3.5. Please, take a look at those (search for "FUZZY: value changed" string) and update your localization.

2) You have many (125) obsolete strings. Those are entities that we do not use anymore - so it does not make sense to localize them. I will attach the list in the next attachment.
Comment 58 Zibi Braniecki [:gandalf][:zibi] 2009-04-06 16:29:53 PDT
Created attachment 371341 [details]
obsolete entities

Attaching list of obsolete entities
Comment 59 kilinux-team 2009-04-07 02:36:56 PDT
(In reply to comment #58)
Thank you for the latest firefox update. I have removed 125 absolete strings and the team started translation work . I will submit a complete translated kiswahili package next week.
Comment 60 Emanuel Feruzi 2009-04-12 04:49:17 PDT
Created attachment 372286 [details]
sw-TZ Files of Fx 3.5 by 20090410

these files still has access key issues but we are looking at them.
Comment 61 Emanuel Feruzi 2009-04-12 04:52:16 PDT
(In reply to comment #59)
> (In reply to comment #58)
> Thank you for the latest firefox update. I have removed 125 absolete strings
> and the team started translation work . I will submit a complete translated
> kiswahili package next week.

May you please post the PO Files so that I can compare to what we have.
Comment 62 Emanuel Feruzi 2009-04-12 15:08:40 PDT
Created attachment 372332 [details]
sw-TZ Files 

Team, here is the latest copy of the PO files that we have been cleaning up the whole day. We have managed to clean up the access keys 429 to about 94. We will do a build in the morning and make it available for testing. Alberto was to do a build tonight but I had not merged the conflicts resolutions so he promised to have the tests but morning.

I will post the next development at noon tomorrow. If you have any issues with the files please let me know and we can work it out together.
Comment 63 Emanuel Feruzi 2009-04-12 15:18:15 PDT
We updated our Glossary as soon as we have more than 15 new words and we make in available for all those that want to make use of it. The current version which was updated on the 20090412 can be found on this link below:

http://linuxgroup.co.tz/files/tzLUG-Glossary.20090412.po - Glossary
Comment 64 Emanuel Feruzi 2009-04-13 06:24:39 PDT
(In reply to comment #62)
> Created an attachment (id=372332) [details]
> sw-TZ Files 
> 
> Team, here is the latest copy of the PO files that we have been cleaning up the
> whole day. We have managed to clean up the access keys 429 to about 94. We will
> do a build in the morning and make it available for testing. Alberto was to do
> a build tonight but I had not merged the conflicts resolutions so he promised
> to have the tests but morning.
> 
> I will post the next development at noon tomorrow. If you have any issues with
> the files please let me know and we can work it out together.

New files and XPI are now available for testing at thus URL:

http://svn.it46.se/svn/umoja/firefox/trunk/13apr/

Sebastian and I are looking at finishing all the outstanding work and submit the files to Alberto for building packs. We will meet on Wednesday to start testing. We had been looking for a users with Mac and so far we have only one. If we can get at least 5 to test for at least two days, it will be nice. Kilinux may you please assist us in summing up testers and gathering the feedbacks.
Comment 65 Emanuel Feruzi 2009-04-13 11:50:08 PDT
Created attachment 372436 [details]
sw-TZ-20090413-RC1

We have manage to do about 99.5% of the work cleaned up. I have been testing the XPI on both windows and Linux. Its looking good and with a few more hours we can get it all up and cleaned up. For those that wants to give it  a try please do and tell you friends too. Below are the links for the XPI and ReadMe. I will write a non-geek HowTo for testing purposes. 

XPI: http://svn.it46.se/svn/umoja/firefox/trunk/xpi/firefox-3.5b4pre.sw.langpack.xpi
ReadMe: http://svn.it46.se/svn/umoja/firefox/trunk/xpi/firefox-3.5b4pre.sw.langpack.xpi

I will make sure to keep an eye on this thread just in case new comments and ideas come up.

We are almost there. Keep on working on it.
Comment 66 Emanuel Feruzi 2009-04-13 11:53:07 PDT
Correct ReadMe Link:

http://svn.it46.se/filedetails.php?repname=Umoja&path=%2Ffirefox%2FREADME
Comment 67 kilinux-team 2009-04-16 01:16:04 PDT
(In reply to comment #63)
> We updated our Glossary as soon as we have more than 15 new words and we make
> in available for all those that want to make use of it. The current version
> which was updated on the 20090412 can be found on this link below:
> 
> http://linuxgroup.co.tz/files/tzLUG-Glossary.20090412.po - Glossary

Its nice that you have a glossary but we see it contains many terms created by Kilinux Project so you need to explain how did you team create it. We found new terms but which criteria did you use to translate them. For example:  baseline (Juu ya mstari msingi), blank space (nafasi sawa), boot disk (Diski Ngumu), boot drive (kiendeshe lengwa), clipboard (pachick ubaopogoa), cover-page (safu-wima ukurasa) etc. I don't think if this is a good glossary because we can't translate like this way and there is so many terms with wrong translation. I think it will be good to review your glossary and know the techniques of creating terms used in Kiswahili language.

:/Kenny
Comment 68 Emanuel Feruzi 2009-04-16 01:28:15 PDT
(In reply to comment #67)
> (In reply to comment #63)
> > We updated our Glossary as soon as we have more than 15 new words and we make
> > in available for all those that want to make use of it. The current version
> > which was updated on the 20090412 can be found on this link below:
> > 
> > http://linuxgroup.co.tz/files/tzLUG-Glossary.20090412.po - Glossary
> 
> Its nice that you have a glossary but we see it contains many terms created by
> Kilinux Project so you need to explain how did you team create it. We found new
> terms but which criteria did you use to translate them. For example:  baseline
> (Juu ya mstari msingi), blank space (nafasi sawa), boot disk (Diski Ngumu),
> boot drive (kiendeshe lengwa), clipboard (pachick ubaopogoa), cover-page
> (safu-wima ukurasa) etc. I don't think if this is a good glossary because we
> can't translate like this way and there is so many terms with wrong
> translation. I think it will be good to review your glossary and know the
> techniques of creating terms used in Kiswahili language.
> 
> :/Kenny

Like I said in the email we did not reinvent the wheel. I believe this glossary is the same you used or developed at start. All we did is we bought a copy of TUKI and the Standard English-Swahili dictionary and a number of online resources like Kamusi Project and others to try and feel in the gapes. But most of the terms are still as we received the files from IT+46. But we can revise them.
Comment 69 kilinux-team 2009-04-16 02:14:38 PDT
(In reply to comment #68)
> (In reply to comment #67)
> > (In reply to comment #63)
> > > We updated our Glossary as soon as we have more than 15 new words and we make
> > > in available for all those that want to make use of it. The current version
> > > which was updated on the 20090412 can be found on this link below:
> > > 
> > > http://linuxgroup.co.tz/files/tzLUG-Glossary.20090412.po - Glossary
> > 
> > Its nice that you have a glossary but we see it contains many terms created by
> > Kilinux Project so you need to explain how did you team create it. We found new
> > terms but which criteria did you use to translate them. For example:  baseline
> > (Juu ya mstari msingi), blank space (nafasi sawa), boot disk (Diski Ngumu),
> > boot drive (kiendeshe lengwa), clipboard (pachick ubaopogoa), cover-page
> > (safu-wima ukurasa) etc. I don't think if this is a good glossary because we
> > can't translate like this way and there is so many terms with wrong
> > translation. I think it will be good to review your glossary and know the
> > techniques of creating terms used in Kiswahili language.
> > 
> > :/Kenny
> 
> Like I said in the email we did not reinvent the wheel. I believe this glossary
> is the same you used or developed at start. All we did is we bought a copy of
> TUKI and the Standard English-Swahili dictionary and a number of online
> resources like Kamusi Project and others to try and feel in the gapes. But most
> of the terms are still as we received the files from IT+46. But we can revise
> them.

Feruzi the kiswahili resources you have said did no have any of the ICT terms. That why kilinux technical team worked with linguistic team to create the terms you used in tzLUG-Glossary. IT+46 does not use Kiswahili experts and has Kilinux-Glossary, so state clear and include the efforts of Kilinux in your Glossary and our team can review it. On our side we have arranged a session with linguistic team to translate our new terms and improve our Kilinux Glossary. Most of the terms which were not translated in your glossary are found in our extended glossary and Alberto has it.
Comment 70 Emanuel Feruzi 2009-04-16 02:20:21 PDT
(In reply to comment #69)
> (In reply to comment #68)
> > (In reply to comment #67)
> > > (In reply to comment #63)
> > > > We updated our Glossary as soon as we have more than 15 new words and we make
> > > > in available for all those that want to make use of it. The current version
> > > > which was updated on the 20090412 can be found on this link below:
> > > > 
> > > > http://linuxgroup.co.tz/files/tzLUG-Glossary.20090412.po - Glossary
> > > 
> > > Its nice that you have a glossary but we see it contains many terms created by
> > > Kilinux Project so you need to explain how did you team create it. We found new
> > > terms but which criteria did you use to translate them. For example:  baseline
> > > (Juu ya mstari msingi), blank space (nafasi sawa), boot disk (Diski Ngumu),
> > > boot drive (kiendeshe lengwa), clipboard (pachick ubaopogoa), cover-page
> > > (safu-wima ukurasa) etc. I don't think if this is a good glossary because we
> > > can't translate like this way and there is so many terms with wrong
> > > translation. I think it will be good to review your glossary and know the
> > > techniques of creating terms used in Kiswahili language.
> > > 
> > > :/Kenny
> > 
> > Like I said in the email we did not reinvent the wheel. I believe this glossary
> > is the same you used or developed at start. All we did is we bought a copy of
> > TUKI and the Standard English-Swahili dictionary and a number of online
> > resources like Kamusi Project and others to try and feel in the gapes. But most
> > of the terms are still as we received the files from IT+46. But we can revise
> > them.
> 
> Feruzi the kiswahili resources you have said did no have any of the ICT terms.
> That why kilinux technical team worked with linguistic team to create the terms
> you used in tzLUG-Glossary. IT+46 does not use Kiswahili experts and has
> Kilinux-Glossary, so state clear and include the efforts of Kilinux in your
> Glossary and our team can review it. On our side we have arranged a session
> with linguistic team to translate our new terms and improve our Kilinux
> Glossary. Most of the terms which were not translated in your glossary are
> found in our extended glossary and Alberto has it.

No worries, please review them and send the revised version I will hack a script will help us locate the affected strings and we will change them. I do not see that as a problem. How long will it take for you to review the terms? I would suggest that you write a script that will pick the the words are different and only work on those.
Comment 71 kilinux-team 2009-04-16 02:28:26 PDT
Thanks but we need to review it with your team so that next time we will not expect a wrong translation and we are ready to train your team on techniques for creating Kiswahili terms. Welcome if you are ready with your team

:/Kilinux Team
Comment 72 Emanuel Feruzi 2009-04-16 02:36:35 PDT
Give us a three possible dates that we can come and we get organized and come and get the training. We will really appreciate that and thank you in advance.
Comment 73 kilinux-team 2009-04-16 02:46:18 PDT
You may come on monday next week at University Of Dar es salaam - Kilinux Office (Mathematics building) so that we can organize together on how to go about it. We available all the time up to 16:00hrs. Welcome
Comment 74 Ali Ayub Kalufya 2009-04-16 03:03:10 PDT
Many congratulations to Feruzi and his team for coming up with an extended Firefox translation. 
Although some of vocabs may seem unpalatable to some, I suggest we maintain the spirit of adding and integrating with popular translations as they come. Instead of dropping/replacing I advise adding on and let the audience pick what seems more plausible. 
In the beginning, I set up a web site and held workshops in several Tanzanian rural areas for collecting popular translations. The results was the very first translation of Firefox with imagery chosen by folks in rural Tanzania. I believe this is the way to go, not the otherwise imposition of terms that would make the resulting software not popular among the masses.
Although I passed leadership of this group to the KiLinux team, this should not mean it has mandate to dictate what should be used as "right" translation. We should share whatever we gather and let time decide which of translations will stick. KiLinux team may remain as lead but this translation effort should remain open to all interested and with something to contribute. That is how it started and benefited a lot since beginning.
Comment 75 kilinux-team 2009-04-16 03:21:53 PDT
T(In reply to comment #74)
> Many congratulations to Feruzi and his team for coming up with an extended
> Firefox translation. 
> Although some of vocabs may seem unpalatable to some, I suggest we maintain the
> spirit of adding and integrating with popular translations as they come.
> Instead of dropping/replacing I advise adding on and let the audience pick what
> seems more plausible. 
> In the beginning, I set up a web site and held workshops in several Tanzanian
> rural areas for collecting popular translations. The results was the very first
> translation of Firefox with imagery chosen by folks in rural Tanzania. I
> believe this is the way to go, not the otherwise imposition of terms that would
> make the resulting software not popular among the masses.
> Although I passed leadership of this group to the KiLinux team, this should not
> mean it has mandate to dictate what should be used as "right" translation. We
> should share whatever we gather and let time decide which of translations will
> stick. KiLinux team may remain as lead but this translation effort should
> remain open to all interested and with something to contribute. That is how it
> started and benefited a lot since beginning.

Can you give a link to the work you have done concerning translations. Kilinux do not mandate instead we need to have a good Kiswahili glossary. This is possible if we can work together and Kilinux want to share the approach it uses in creating terms. Its totally impossible to have terms with different meaning to be used in Kiswahili localized software. Your comments imply that each team use its own translations and the users will select what is good for them.
Comment 76 Emanuel Feruzi 2009-04-20 01:24:47 PDT
Created attachment 373625 [details]
RC1 - Review 1

We have been reviewing the language pack. Areas that we have focused on this first round of review is the main menu, correcting of access keys and command access keys and misspelled words that showed up. We are looking at spending more time an energy on an issues that were expressed by the Kilinux: incomplete, misspelled and wrongly translated words.
Comment 77 Emanuel Feruzi 2009-06-11 02:33:17 PDT
Created attachment 382685 [details]
sw-TZ RC2

A number of Swahili speaker have taken their time to look at our works and sent us some reviews. I am working on an easier way for people to submit their reviews. But for now here is a new build based on the reviews.
Comment 78 kilinux-team 2009-06-12 03:28:51 PDT
Kilinux team succeeded to finish a new Extended Kiswahili Glossary and it is available for download through the link below.
 
http://www.kilinux.udsm.ac.tz/kiblog/documents/glossary/sw_TZ_Extended_glossary.xls

Currently the glossary consists of 1685 terms among them only 4 terms remained untranslated is available in xls format and it can be opened using either excel(MS Office) or Calc(OpenOffice.org). We are still preparing its corresponding PO , PDF and Writer formats
Comment 79 kilinux-team 2009-06-12 03:38:36 PDT
Kilinux team accepts suggestions and comments on the Extended-Glossary
Comment 80 Emanuel Feruzi 2009-06-12 05:30:23 PDT
Please check if the link is correct as I can not seem to be able to down load it.
Comment 81 kilinux-team 2009-06-14 22:30:31 PDT
The link is working but if you fail to download visit our website www.kilinux.udsm.ac.tz you will find it
Comment 82 Seth Bindernagel 2010-04-08 10:29:30 PDT
It seems that both the tzLug and Kilinux teams have decided to generate one version of Swahili, moving closer to becoming an official localization.  I am resolving this incomplete for now to due some registration bug maintenance.  Please reopen when you are ready to move forward with one version of sw-TZ.  Thanks!  Glad to see us progressing here.
Comment 83 Emanuel Feruzi 2010-04-09 01:55:23 PDT
On behalf of the tzLUG Team, I say we move on.

Note You need to log in before you can comment on or make changes to this bug.