The default bug view has changed. See this FAQ.

since 20050723: cannot install themes

RESOLVED FIXED in mozilla1.8final

Status

()

Toolkit
Add-ons Manager
P1
major
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: philippe (part-time), Assigned: bz)

Tracking

unspecified
mozilla1.8final
PowerPC
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050723 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050723 Firefox/1.0+

With build 20050323, it is apparently impossible to install a theme.

* dropping a theme jar file in the extensions folder just does nothing. Firefox
doesnot attempt to register the theme.
JS console reports the following
A Item Package appeared at: /Users/phiw/Library/Application
Support/Firefox/Profiles/1h0sbxi6.default/extensions/GrappleProP2.4.jar that we
know nothing about, assuming it was dropped in by the user and configuring for
installation now. Location Key: app-profile


Error: Components.classes['@mozilla.org/xpcom/version-comparator;1'] has no
properties
Source File:
file:///Applications/DeerPark.app/Contents/MacOS/components/nsExtensionManager.js
Line: 172

On starting up, the browser does not attempt to open the jar file and no warning
window appears (wnat to install something... Install - whatever the exact wordings.
The theme does not appear in the Theme manager.

* Downloading a theme from https://addons.mozilla.org/
results in the following:
- the theme downloads and briefly appears in the Theme manager window.
- when download finished, the theme vanishes out of the theme manager window.

Js console reports the following:
Error: Components.classes['@mozilla.org/xpcom/version-comparator;1'] has no
properties
Source File:
file:///Applications/DeerPark.app/Contents/MacOS/components/nsExtensionManager.js
Line: 172

Error: installLocation has no properties
Source File:
file:///Applications/DeerPark.app/Contents/MacOS/components/nsExtensionManager.js
Line: 6327

After restarting, the theme is not found in the extensions folder.

Reproducible: Always

Actual Results:  
no custom theme available

Expected Results:  
display the custom theme in the Theme Manager window, allow to activate.

I previously submitted bug 301872: Previously installed and active theme does
not display, browser reverts to default theme. Both bugs are related.
The version-comparator was caused by bug 300731

The installLocation has no properties will be fixed by the patch in bug 296566
Blocks: 300731
Depends on: 296566
Assignee: nobody → benjamin
Status: UNCONFIRMED → NEW
Ever confirmed: true
http://lxr.mozilla.org/mozilla/search?string=version-compar

I don't get it... didn't I get the contractid correct? What am I missing?

Comment 3

12 years ago
I cannot find any problems with the comparator Contract ID and, more
importantly, installing themes from addons.mozilla.org works great in this
nightly build.

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b4) Gecko/20050724
Firefox/1.0+

I do however have a problem installing by dropping in the profile's extensions
folder, though a totally different one to the reporter. After the message about
a new file appearing, I get:

Error: commonName is not defined
Source File:
file:///C:/Program%20Files%20(x86)/Deer%20Park%20Alpha%202/components/nsExtensionManager.js
Line: 2664

I am therefor unable to reproduce either part of the bug exactly, and only one
bit in net effect.

It also occurs to me that the bug says 2005*03*23. Is this a transcription error
for 20050723, the date it was filed and the buildID used? I guess it probably was.
The "commonName" error is due to bug 240661... I'm suspecting now that
yesterday's nightly may have had had a mid-checkin tree causing the contractid
error.

Boris, did you mean to change commonName to prettyName at
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/mozapps/extensions/src/nsExtensionManager.js.in&mark=2673#2663
(Reporter)

Comment 5

12 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050724
Firefox/1.0+ ID:2005072410

With this build, I was able to install a theme by downloading form
addons.mozilla.org. No problems at all, and the theme works.

*but*
I was unable to install a theme by dropping the jar file into the extension folder.

Js console:

A Item Package appeared at: /Users/phiw/Library/Application
Support/Firefox/Profiles/1h0sbxi6.default/extensions/GrappleProP2.4.jar that we
know nothing about, assuming it was dropped in by the user and configuring for
installation now. Location Key: app-profile

Error: commonName is not defined
Source File:
file:///Applications/DeerPark.app/Contents/MacOS/components/nsExtensionManager.js
Line: 2515
(Reporter)

Updated

12 years ago
Summary: since 20050323: cannot install themes → since 20050723: cannot install themes
Created attachment 190360 [details] [diff] [review]
Doh
Attachment #190360 - Flags: review?(mconnor)
Attachment #190360 - Flags: approval1.8b4?

Updated

12 years ago
Attachment #190360 - Flags: review?(mconnor)
Attachment #190360 - Flags: review+
Attachment #190360 - Flags: approval1.8b4?
Attachment #190360 - Flags: approval1.8b4+
Assignee: benjamin → bzbarsky
Priority: -- → P1
Target Milestone: --- → Firefox1.1
fixed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.