Alt+NUM (tab jumping) cannot be localized

RESOLVED FIXED

Status

()

Core
Internationalization
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: zwnj, Assigned: smontagu)

Tracking

(Blocks: 1 bug)

Trunk
All
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; he-IL; rv:1.7.6) Gecko/20050524 Firefox/1.0.4 (Ubuntu package 1.0.2 MFSA2005-44)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; he-IL; rv:1.7.6) Gecko/20050524 Firefox/1.0.4 (Ubuntu package 1.0.2 MFSA2005-44)

Alt+NUM, which used for jumping tab to tab, doesn't work with ARABIC-INDIC
DIGITs and EXTENDED ARABIC-INDIC DIGITs.

Using Unicode's numerical value of a glyph is better than just check the ASCII
NUMBERs.  But don't know how to solve Bug 301896 with this model.

Putting them on translatable (dtd|properties) files help to solve the reverse
problem, but may couse some other i18n problems.


Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

12 years ago
Summary: Alt+NUM cannot be localized → Alt+NUM (tab jumping) cannot be localized
(Reporter)

Updated

12 years ago
Blocks: 285718
(Reporter)

Updated

12 years ago
Blocks: 301896
(Reporter)

Comment 1

11 years ago
This bug is very annoying in non-Latin scripts.  Is it possible to get it fixed
for ff2.0?

DEP: Bug 69230 -- Accelerators should not be affected by keyboard group/level?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

11 years ago
Isn't this a dupe of bug 298004 (fixed on trunk)?
(Reporter)

Comment 3

11 years ago
It wasn't a DUP of 298004, but that feature fixes this request.  Note that Bug 69230 could fix this request in many cases too.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Depends on: 298004
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.