Last Comment Bug 302168 - Valid calculate MIPs generate MDG loop error
: Valid calculate MIPs generate MDG loop error
Status: RESOLVED WONTFIX
:
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: xforms
: Stephen Pride
Mentors:
http://www.mozilla.org/projects/xforms/
Depends on: 265212
Blocks: 326372 326373
  Show dependency treegraph
 
Reported: 2005-07-26 00:40 PDT by Allan Beaufour
Modified: 2016-07-15 14:46 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Testcase (1.62 KB, application/xhtml+xml)
2005-07-26 00:52 PDT, Allan Beaufour
no flags Details

Description Allan Beaufour 2005-07-26 00:40:56 PDT
As I wrote in bug 301413, we still have a problem in the MDG regarding loops.

The problem is that using expressions with predicates the MDG sometimes collects
to many dependencies. If the expressions are calculate MIPs a loop will exist in
the MDG graph, making the rebuild fail.
Comment 1 Allan Beaufour 2005-07-26 00:52:41 PDT
Created attachment 190522 [details]
Testcase

Here's a testcase for it.
Comment 2 Allan Beaufour 2005-07-26 01:12:16 PDT
(In reply to comment #1)
Attachment 190522 [details] fails because the MDG fails to see that '[2]' is a constant
predicate, and thus adds '/root/useArray/use/dont' (all three dont nodes) as a
dependency to both bind 'use1dont' and 'use3dont', resulting in:
use[1]/dont => use[3]/dont => use[1]/dont

I think this should be done as part of bug 265212, as I would rather leave code
that needs to die alone...
Comment 3 David Bolter [:davidb] 2016-02-04 12:21:39 PST
RIP xforms

Note You need to log in before you can comment on or make changes to this bug.