Last Comment Bug 302509 - widgets/preferences.xml depends on (browser) preferences
: widgets/preferences.xml depends on (browser) preferences
Status: RESOLVED DUPLICATE of bug 350528
:
Product: Toolkit
Classification: Components
Component: Preferences (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Nobody; OK to take it and work on it
: Neil Deakin
Mentors:
http://lxr.mozilla.org/seamonkey/sour...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 07:48 PDT by Axel Hecht
Modified: 2006-08-28 23:19 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Axel Hecht 2005-07-28 07:48:15 PDT
I tried to use the new preferences dialog widgets for my xulrunner application,
and it's failing miserably, because it doesn't fall back nicely for missing 
preferences.

Or maybe these prefs should move from 

http://lxr.mozilla.org/seamonkey/source/browser/app/profile/firefox.js#376
http://lxr.mozilla.org/seamonkey/source/mail/app/profile/all-thunderbird.js#165

into something like all-toolkit.js. Or the code in preferences.xml should check
for it's platform itself.

browser.preferences.instantApply and browser.preferences.animateFadeIn are the
prefs.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-08-28 23:19:12 PDT

*** This bug has been marked as a duplicate of 350528 ***

Note You need to log in before you can comment on or make changes to this bug.