Closed Bug 350528 Opened 14 years ago Closed 14 years ago

XULRunner needs to ship with some additional preferences

Categories

(Toolkit Graveyard :: XULRunner, defect)

1.8 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.8.1

People

(Reporter: bent.mozilla, Assigned: bent.mozilla)

References

Details

(Keywords: fixed1.8.1, Whiteboard: [XULRunner 1.8.1 blocker+])

Attachments

(1 file, 1 obsolete file)

browser.preferences.instantApply and browser.preferences.animateFadeIn are required to have preferences.xml work. These should be added to xulrunner.js or preferences.xml should be modified to fall back on a default value if they don't exist. I think it's easier to add the prefs.
Attached patch Patch v1.0 (obsolete) — Splinter Review
This is copied straight from firefox.js
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Attachment #235841 - Flags: first-review?(benjamin)
Attached patch Patch v1.0Splinter Review
Oops, now diff'ed against the latest xulrunner.js
Attachment #235841 - Attachment is obsolete: true
Attachment #235843 - Flags: first-review?(benjamin)
Attachment #235841 - Flags: first-review?(benjamin)
*** Bug 302509 has been marked as a duplicate of this bug. ***
I really think this should make the 1.8 branch, as any xulrunner app that tries to use the preferences widget will be out of luck without these two prefs. It's only adding prefs, after all.
Flags: blocking-firefox2?
Ben, while this would indeed be good, it's not going to be a blocker for the 1.8.1 branch. We'd happily take the patch, though, so make sure that it gets reviewed and landed on trunk and nominate for 1.8.1 approval.
Flags: blocking-firefox2? → blocking-firefox2-
Whiteboard: [would take patch]
Target Milestone: --- → mozilla1.8.1
Comment on attachment 235843 [details] [diff] [review]
Patch v1.0

FWIW, this *is* a XR2 blocker. Perhaps we should file a tracking bug for that, to keep it separate.
Attachment #235843 - Flags: first-review?(benjamin) → first-review+
Whiteboard: [would take patch] → [XULRunner 1.8.1 blocker+]
Fixed on trunk.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Comment on attachment 235843 [details] [diff] [review]
Patch v1.0

Requesting 1.8 approval.
Attachment #235843 - Flags: approval1.8.1?
Comment on attachment 235843 [details] [diff] [review]
Patch v1.0

a=beltzner on behalf of 181drivers
Attachment #235843 - Flags: approval1.8.1? → approval1.8.1+
Fixed on branch.
Keywords: fixed1.8.1
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.