Cmd-D in Bookmarks Manager should not bookmark previous page

RESOLVED FIXED

Status

Camino Graveyard
Bookmarks
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: froodian (Ian Leue))

Tracking

(Blocks: 1 bug)

Details

(URL)

When you open the Bookmarks Manager in a tab/window that has previously
displayed a page and then hit Cmd-D, Camino bookmarks the previous page.

When you open the Bookmarks Manager in a tab/window that has not previously
displayed a page (i.e., blank) and hit Cmd-D, Camino bookmarks about:bookmarks.

When you open History in a new (blank) tab/window, Cmd-D does nothing (beeps);
in a tab/window, Cmd-D also bookmarks the previous page.

Cmd-D should always bookmark the current view, which is about:bookmarks or
about:history when in the BM/History (people may use that to get a quick link to
one of the two on their Bookmarks Bar, for instance).  Three different behaviors
is not good.

Camino 2005072808 (v0.9a2+)
Would some of this be covered in bug 175748?
Bug 175748 seems like the second-most reasonable thing to do with Cmd-D when
displaying Bookmarks, but that would still have Cmd-D doing different things in
History and Bookmarks.

Dunno.  But they probably should be fixed together, and the current behavior(s)
of bookmarking the previous page is clearly a bug.

Comment 3

12 years ago
(In reply to comment #0)
> When you open the Bookmarks Manager in a tab/window that has previously
> displayed a page and then hit Cmd-D, Camino bookmarks the previous page.

Wasn't this intentional behavior to compensate for the fact that it's no longer possible to bookmark a page by dragging the favicon from the URL bar (which at one time still showed the page you were on)?  I can't find the bug offhand, but I think that's the intended behavior.

Comment 4

12 years ago
This is intend behavior, we should not remove it.
No, this was an oversight from fixing that bug (215235); there was never any discussion of this as a "compatibility" hack that I was aware of then (or have been able to find since).

Since we're treating the Manager like a separate page and not an overlay, it shouldn't still be acting like an overlay.  The behavior is widely variant and downright confusing; when the same command does 3 different things depending on arcane state information a user is not going to be aware of/distinguish between, it's broken.  (4 if you count the behavior of the plus symbol; see bug 175748.)

I'll say again: Cmd-D should always bookmark the current view.

Comment 6

12 years ago
To summarize from IRC: while it was indeed intentional, it should change since it's unlikely anyone would expect this behavior (i.e., "behaves as designed" isn't always the same as "behaves correctly").
(Assignee)

Updated

12 years ago
Depends on: 347111
(Assignee)

Updated

12 years ago
Assignee: mikepinkerton → stridey
QA Contact: bookmarks
(Assignee)

Comment 7

12 years ago
fixed by bug 347111.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.