"Report Broken Web Site" dialog "Privacy Policy" link does nothing

RESOLVED DUPLICATE of bug 281717

Status

--
minor
RESOLVED DUPLICATE of bug 281717
14 years ago
2 months ago

People

(Reporter: regis.caspar+bz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050728 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050728 Firefox/1.0+

In the "Report Broken Web Site" dialog, in the "Fill out report" page, if you
click on the "Privacy Policy" link, it does nothing. 

Reproducible: Always

Steps to Reproduce:
1. Under the "help" menu, click on "Report Broken Web Site"
2. Agree the privacy policy and press next if needed
3. Click on "Privacy Policy" at the bottom of the page "Fill out report"

Actual Results:  
does nothing

Expected Results:  
open a window or a tab and load the URI stored in the
"extensions.reporter.privacyURL" preference or
"http://reporter.mozilla.org/privacy/"

Patch proposition :
in chrome\content\reporter\reportWizard.xul (into reporter.jar)
@@ -119,7 +119,8 @@
           <hbox>
             <label id="privacyPolicy" class="text-link"
                    value="&reportForm.privacyPolicy.title;"
-                   tooltiptext="&reportForm.privacyPolicy.tooltip;"/>
+                   tooltiptext="&reportForm.privacyPolicy.tooltip;"
+		    onclick="openPrivacyPolicy()"/>
           </hbox>
         </row>
       </rows>
Component: General → Reporter
Product: Firefox → Other Applications

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 281717 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
*** Bug 305794 has been marked as a duplicate of this bug. ***

Updated

2 months ago
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.