Page loads with wrong anchor location unless the page has been cached.

RESOLVED DUPLICATE of bug 60307

Status

()

RESOLVED DUPLICATE of bug 60307
13 years ago
13 years ago

People

(Reporter: kjganong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050729 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050729 Firefox/1.0+

Found:
Using a Red Hat Enterprise Linux 4 machine.  Using the previous nightly build of
firefox as of 7/29/05.  The same problem was reproduced in mozilla 1.7.4

Description:  An anchor in html designated by <a name="S2-SM-YOUR-RHN-PREFS">
doesn't seem to work if the page is large enough and the anchor is far enough
along in the web page.  The page loads and brings you to the wrong location.

Reproducible: Always

Steps to Reproduce:

1. Go to the location:
https://rhn.redhat.com/help/reference/s1-sm-your-rhn.html#S2-SM-YOUR-RHN-PREFS
2. At first, you will be taken to the page's halfway point.  This is not the
location of the given anchor.
3. Refresh the page with caching (hit the refresh button)
4. The page will load and take you to the correct location.
5. Refresh the page without caching (hold shift and hit the refresh button)
6. The page will load in the incorrect location noted previously.

Actual Results:  
Given in steps.

Expected Results:  
The correct anchor location should be used every time, regardless of whether a
cache of the page is in use.

Using default theme.

Comment 1

13 years ago
Duplicate of Core bug 60307?

Comment 2

13 years ago
Confirmed and still present in Firefox 1.5!
Probably it is really related to bug 60307.

Here is another link to test the bug:
http://c-jump.com/pagerules02.html#aswitch

Comment 3

13 years ago
And here is another duplicate: bug 126882.

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 60307 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.