Each favicon in sidebar are truncated at the bottom

VERIFIED DUPLICATE of bug 301776

Status

()

VERIFIED DUPLICATE of bug 301776
13 years ago
13 years ago

People

(Reporter: tracy, Assigned: philor)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
Seen on Windows and linux DP builds on 2005/08/01

-Open the bookmarks sidebar
-open the quick search folder

for comparison:
-Open the Google quicksearch page

tested results:
notice each of the icons in the sidebar are cut off at the bottom. Compare to
the favicon of the Tab icon. 

expected results:  the favicons should not be truncated.
(Reporter)

Comment 1

13 years ago
This is not a problem on Mac
Hardware: All → PC
I'm guessing this regressed because of bug 301776, but whether that bug is
responsible for this bug or just exposed this bug I don't know.
(Reporter)

Comment 3

13 years ago
This affects the icons in history sidebar as well.
Flags: blocking-aviary1.5?
(Assignee)

Comment 4

13 years ago
*** Bug 303308 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

13 years ago
Created attachment 191533 [details] [diff] [review]
Little more min-height

If you add 2 px of top- and bottom-margin, you're likely to need to increase
the min-height.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #191533 - Flags: review?(mconnor)

Comment 6

13 years ago
Removing request to block 1.5 since the 1.5flags are not being used anymore and
requesting to block 1.8b4.
Flags: blocking-aviary1.5? → blocking1.8b4?

Updated

13 years ago
Flags: blocking1.8b4? → blocking1.8b4-

Comment 7

13 years ago
Created attachment 194003 [details] [diff] [review]
mRowHeight added border+padding

The hight of one row |mRowHeight| should be calculated as margin + border +
padding + height, shouldn't it?
Current code ignores borders and paddings (thus current |height| contains such
stuff instead).
In my patch, the line "height: 1.3em" is changed in order not to change the
current UI.

Other sources that should be corrected with this patch:
http://lxr.mozilla.org/mozilla/source/layout/forms/resources/skin/select.css#66

http://lxr.mozilla.org/mozilla/source/mail/themes/qute/mail/tree.css#62
http://lxr.mozilla.org/mozilla/source/themes/classic/global/mac/tree.css#71
http://lxr.mozilla.org/mozilla/source/themes/classic/global/win/tree.css#72
http://lxr.mozilla.org/mozilla/source/themes/modern/global/tree.css#69
http://lxr.mozilla.org/mozilla/source/toolkit/themes/pinstripe/global/tree.css#71
Comment on attachment 191533 [details] [diff] [review]
Little more min-height

I'm not going to bump the min-height on all app treerows to fix an app detail
like this.  We should be able to specify a slightly-increased tree row size for
the bookmarks sidebar if that's the best way to fix this.
Attachment #191533 - Flags: review?(mconnor) → review-
(Assignee)

Comment 9

13 years ago
Sending this back to bug 301776, from whence it came, and where it sounds like
it may disappear again.

*** This bug has been marked as a duplicate of 301776 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Comment 10

13 years ago
*** Bug 309123 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.