Closed Bug 303076 Opened 17 years ago Closed 4 years ago

Switching styles and switching back causes loss of first-letter style.

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla57

People

(Reporter: from-mozilla, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

The page at http://www.eschatonic.org/misc/example.html causes Firefox to behave
incorrectly when switching between the preferred and the alternate stylesheet.
On switching to the alternate stylesheet, the text in each paragraph is
duplicated. On switching back to the preferred stylesheet, the text is still
repeated and the p:first-letter style has been lost.


Reproducible: Always

Steps to Reproduce:
1. View -> Page Style -> plain
2. View -> Page Style -> default
3. Reload

Actual Results:  
1. Text is duplicated.
2. Text is still repeated, style is lost.
3. Repeated text is gone, style is restored.

Expected Results:  
1. Text should switch to browser-default color and first-letter size.
2. Text should switch back to color and first-letter size defined in stylesheet
"default".
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050802 Firefox/1.0+ ID:2005080203
Status: UNCONFIRMED → NEW
Component: General → Style System (CSS)
Ever confirmed: true
Product: Firefox → Core
Version: unspecified → Trunk
This is basically bug 229764.  See also bug 167292.
Depends on: 167292
Assignee: nobody → dbaron
QA Contact: general → ian
Assignee: dbaron → nobody
QA Contact: ian → style-system
Currently the duplication on switching style to 'plain' no longer occurs, but the first-letter style is not restored on switching back to 'default'.
Duplicate of this bug: 167292
The remaining issue looks like bug 8253.
Depends on: 8253
Summary: Switching styles causes duplication of text, switching back causes loss of style. → Switching styles and switching back causes loss of first-letter style.
Duplicate of this bug: 320451
HI,

i've got this ...
my class "a.hightlight:first-letter {...}" do not work (dynamically with JS) until i write "a:first-letter {}" after


a.hightlight:first-letter {color:#41608F; } /* not work when class is applied dynamically ? */
a:first-letter {} /* hightlight applied only if i write this after */
sorry don't know what happen but fortunately a:first-letter now work for me...
Fixed by stylo.
Status: NEW → RESOLVED
Closed: 4 years ago
Depends on: stylo
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.