Safe Mode: Starting in Safe Mode should invoke some kind auto diagnostics

NEW
Unassigned

Status

()

--
enhancement
14 years ago
4 years ago

People

(Reporter: jaime.bugzilla, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {ux-error-recovery})

Trunk
Future
ux-error-recovery
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

When the user loads Firefox in safe mode as well as disabling various settings
as extensions etc.. it should person some diagnostic checks on the profile files
in order to determine if there are any problems with them, it should then invoke
a user response to a relevant action.

Such as:

Firefox has detected that your bookmarks/passwords/saved form info/history file
is corrupt, unfortunately it is not possible to recover it, do you wish to
delete it and create a new file (recommended)

Firefox has detected that the extension myFirstExtension is corrupted and
preventing Firefox from loading normally, do you wish to: disable it
(recommended), try reinstalling it, check for updates to it?

Firefox is unable to connect to the internet, please check the following:
Firewall
Proxy
etc..

This is related to bug 303279, this bug is about doing some automated checks,
bug 303279 is more ago guiding the user through some manual checks.

I'm not sure what level of checks of extension/theme etc.. files for correctness
is possible or how it would be accomplished however ways of doing so should be
investigated to improve the user experience.

Firefox should thus be able to self heal (with relevant user prompts) from most
extension/theme/configuration issues.
Might want to check to see if there are way to examine logfiles or look for
.lock files or te like in order to help these diagnostic tests. Further, it
might be nice if the standard firefox binary looked for these situations and
automatically loaded into safe-mode to handle them.

Comment 2

13 years ago
Mike, you should probably be in charge of pushing this bug and/or filing sub-bugs about particular data we should diagnose.
Assignee: nobody → beltzner

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 304403 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

11 years ago
Assignee: beltzner → nobody
Status: REOPENED → NEW
Target Milestone: --- → Future
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Updated

8 years ago
Depends on: 599572
Keywords: ux-error-recovery
OS: Windows XP → All
Hardware: x86 → All

Updated

8 years ago
Blocks: 599835

Updated

8 years ago
Depends on: 429306
You need to log in before you can comment on or make changes to this bug.