All users were logged out of Bugzilla on October 13th, 2018

"download all headers" only downloads 500 headers

VERIFIED DUPLICATE of bug 26146

Status

P3
normal
VERIFIED DUPLICATE of bug 26146
19 years ago
14 years ago

People

(Reporter: waterson, Assigned: sspitzer)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
alecf sez it's a hard-coded limit that needs to be removed or something.

To reproduce:

. Choose a newsgroup that you're subscribed to with a lot of new unread posts 
(you may need to unsubscribe/resubscribe to a newsgroup to get into this 
state).

. The "Download Headers For" dialog will come up.

. Select "Download all headers", and click ok.

Expected: all headers will download
Actual: only 500 headers download
(Reporter)

Comment 1

19 years ago
marking beta1. my guess is that the fix is easy, low-risk, and that there'll be 
a large number of bugs filed if it goes out like it is.
Keywords: beta1

Comment 2

19 years ago
it's not a hardcoded limit - the default pref for maximum download when not in
download-all mode is 500... I think the problem is that it's not acknowledging
that we're in download-all mode.
no, it's not a hard coded limit problem.

the problem is the "download all headers" button isn't hooked up yet.

the problem is that I need to fix openWindow() in nsNNTPNewsgroupList.cpp

I'm opening the window up with no way to get back ok / cancel or user decisions.

I think all that works is changing the max articles or changing the "mark all
read" checkbox.

this is really a duplicate of bug #26146

I'll mark that bug beta1.

*** This bug has been marked as a duplicate of 26146 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 4

19 years ago
Mark it verified/dup.
Status: RESOLVED → VERIFIED
QA Contact: lchiang → fenella
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.