On app upgrade (when extension version changes), check with update server for *downgrade* of extension maxversion

RESOLVED FIXED

Status

()

RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: benjamin, Assigned: rstrong)

Tracking

Trunk
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

13 years ago
As an additional protection measure, we want to be able to downgrade the
extension maxversion setting based on the settings from the update server. This
means that whenver the extension version gets changed, we need to check with the
update server for every extension, not just the extensions that are obviously
incompatible.

Please let me know how hard you think this is and whether you think this is
unfeasible for the 1.8 cycle... it affects some decisions we are making about
how we plan to version firefox 1.5.x.
(Reporter)

Updated

13 years ago
Flags: blocking1.8b4+
This would be very easy to do quickly... I should have a patch by Sunday evening
California time.
Missed my self-imposed deadline... I should have time this evening to do this.
Created attachment 192084 [details] [diff] [review]
patch in progress

This does what we want but there is additional cleanup and documentation still
to be done.
Created attachment 192163 [details] [diff] [review]
patch

This has more clean up in it than I originally planned to do but it needed it.
I also found a bug with getIncompatibleItemList where appManaged items were
returned when includeDisabled is true. The versionUpdateOnly in param for
update is a long though it is usually called using a boolean. This allowed me
to use a value of 2 for applying the found app compatibility info during a
version only check in order to downgrade. Not the best solution but it does
accomplish the desired result.
Attachment #192084 - Attachment is obsolete: true
Attachment #192163 - Flags: review?(benjamin)
(Reporter)

Updated

13 years ago
Attachment #192163 - Flags: review?(benjamin)
Attachment #192163 - Flags: review+
Attachment #192163 - Flags: approval1.8b4+
Created attachment 192271 [details] [diff] [review]
patch for checkin

The only change is passing the app.extennsions.version to
getIncompatibleItemList from update.js which turns out is required from outside
of the EM. I can't get a hold of bsmedberg on irc so re-requesting.
Attachment #192163 - Attachment is obsolete: true
Attachment #192271 - Flags: review?
Attachment #192271 - Attachment is obsolete: true
Attachment #192271 - Flags: review?
Created attachment 192275 [details] [diff] [review]
check version in getIncompatibleItemList and use undefined as appropriate
Attachment #192275 - Flags: review?(benjamin)
(Reporter)

Updated

13 years ago
Attachment #192275 - Flags: review?(benjamin)
Attachment #192275 - Flags: review+
Attachment #192275 - Flags: approval1.8b4+
Fixed for 1.8b4

Checking in mozilla/toolkit/mozapps/extensions/public/nsIExtensionManager.idl;
/cvsroot/mozilla/toolkit/mozapps/extensions/public/nsIExtensionManager.idl,v 
<--  nsIExtensionManager.idl
new revision: 1.40; previous revision: 1.39
done
Checking in mozilla/toolkit/mozapps/extensions/src/nsExtensionManager.js.in;
/cvsroot/mozilla/toolkit/mozapps/extensions/src/nsExtensionManager.js.in,v  <--
 nsExtensionManager.js.in
new revision: 1.141; previous revision: 1.140
done
Checking in mozilla/toolkit/mozapps/extensions/content/update.js;
/cvsroot/mozilla/toolkit/mozapps/extensions/content/update.js,v  <--  update.js
new revision: 1.17; previous revision: 1.16
done
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
*** Bug 339949 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.