Toolbars jump briefly when first page starts to load in newly-opened browser

RESOLVED FIXED in Firefox1.5

Status

()

Firefox
Toolbars and Customization
--
minor
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Wayne Woods, Assigned: Bryan)

Tracking

({fixed1.8, regression})

Trunk
Firefox1.5
fixed1.8, regression
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

13 years ago
Can't see a dupe for this...

In recent nightlies in Windows XP, the toolbars do a quick "jump" when you first
go to load a page in a freshly-opened browser. It seems to affect both the
bookmarks and navigation toolbars, as well as the tab bar if multiple (blank)
tabs are open.

To reproduce this, set your start page as blank, so it doesn't automatically go
to a page upon opening. Then open a bookmark or go to a url. You should see the
toolbars distort very briefly before the page starts drawing.

The symptoms don't occur in a fresh window if you've already visited sites in
another window. You have to close the browser and start afresh to reproduce it.

However the symptoms do occur if you do things like open more (blank) tabs
before loading your first page. It only seems to care that it's the very first
page being loaded.

Reproduced with the latest Win XP nightly. Doesn't seem to be an issue in Mac OS
X builds, though.

Sorry I can't pinpoint this more closely. I only use Windows at work, and don't
have the ability to maintain a heap of nightly builds there. It seems to be
pretty recent, though.

Comment 1

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050810
Firefox/1.0+ ID:2005081004

Changing to trivial since this is no biggy by any stretch of the imagination
(assuming it can be reproduced).
Severity: normal → trivial
Summary: Toolbars jump briefly when first page starts to load in newly-opened browser → Toolbars jump briefly when first page starts to load in newly-opened browser
Yes, I see this also. It has been discussed on the forum:
http://forums.mozillazine.org/viewtopic.php?p=1664744#1664744
It still worked fine in this build: 2005080703
(Reporter)

Comment 3

13 years ago
I can also confirm that it still shows symptoms using a fresh profile, having
completely erased the old application directory before installing the latest
Deer Park nightly.
regressed from bug 253661 ?

Comment 5

13 years ago
The given testcase did not work, however after reading on mozillazine, I found
that boxerboi had to click on the home icon to reproduce this. Sure enough,
that's what I had to do. If anyone else is having problems reproducing this, try
clicking on the home icon.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050810
Firefox/1.0+ ID:2005081004
Version: unspecified → Trunk

Comment 6

13 years ago
With a fresh Profile, the "jumping" stopped for the same url after the second
(successful) try. Naturally always did a restart of Fx after the "jumping".
(Perhaps didnt give the 1. try enough time to load completely...)
Anyway, after deleting the Browser Cache, "jumping" for that url was back again.
So Cache (and its setings) may be involved somehow.
Tested with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050810 Firefox/1.0+ ID:2005081006 

Comment 7

13 years ago
Here is perhaps a different way to reproduce this (if we are talking about the
same behavior)-
I always hide the bookmarks toolbar and drag the actual bookmarks up next to the
help menu (and homepage is about:blank).
If you do this you see bar that starts with file, and the bar that starts with
the left arrow, move down by about one pixel as the window is first opening. 
Each time you press ctrl-N it does it.
(Reporter)

Comment 8

13 years ago
Comment 7 sounds a bit different, although maybe they share the same underlying
cause. Cass, do you know when your symptoms first began? In a recently trunk
nightly?
(Assignee)

Comment 9

13 years ago
All, this will be fixed very soon!  Please see 304394 as i've documented the
cause of the issue and a solution you can implement yourself in userChrome.css.
 Throbber smobber!!!

~B
*** Bug 304394 has been marked as a duplicate of this bug. ***
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 11

13 years ago
Created attachment 192710 [details] [diff] [review]
Add 1px of padding to menubar to fix jumping...

Add 1px of padding to menubar to fix jumping caused by throbber.  This also
resolves the issue one see's when ALT-tabbing between the bookmark manager and
FF while both are maximised (you'll see what looks like menubar jumping between
the two).  Just a little bit of polish thrown in!

~B
Attachment #192710 - Flags: review?(kevin)
(Assignee)

Comment 12

13 years ago
Created attachment 192776 [details] [diff] [review]
One additional tweak to fix horizontal padding...

One additional tweak to fix horizontal padding...
Attachment #192710 - Attachment is obsolete: true
Attachment #192776 - Flags: review?(kevin)
(Assignee)

Updated

13 years ago
Attachment #192710 - Flags: review?(kevin)
(Assignee)

Updated

13 years ago
Flags: blocking1.8b4?

Comment 13

13 years ago
Comment on attachment 192776 [details] [diff] [review]
One additional tweak to fix horizontal padding...

I couldn't apply the patch using the file. I updated my menu.css manually and
it solved the problem. Thanks for working on this. Can you attach a patch that
applies to the branch for posterity? Thanks!
Attachment #192776 - Flags: review?(kevin) → review+
Created attachment 193535 [details] [diff] [review]
Patch that applies

Not sure what happened to that last patch. Here's one that applies, branch and
trunk, carrying over Kevin's r+, and asking for approval for a little UI polish
(regression from bug 253661).
Attachment #192776 - Attachment is obsolete: true
Attachment #193535 - Flags: review+
Attachment #193535 - Flags: approval1.8b4?
Assignee: nobody → BoxerBoi76
Severity: trivial → minor

Updated

13 years ago
Flags: blocking1.8b4? → blocking1.8b4+

Updated

13 years ago
Attachment #193535 - Flags: approval1.8b4? → approval1.8b4+
Trunk:
/cvsroot/mozilla/toolkit/themes/winstripe/global/menu.css; new revision: 1.6;

1.8 Branch:
/cvsroot/mozilla/toolkit/themes/winstripe/global/menu.css; new revision: 1.5.2.1;
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Target Milestone: --- → Firefox1.5
You need to log in before you can comment on or make changes to this bug.