Setting homepage to about:blank causes toolbar to jump when clicking on home or entering an address and hitting enter...

RESOLVED DUPLICATE of bug 304245

Status

SeaMonkey
Themes
--
trivial
RESOLVED DUPLICATE of bug 304245
13 years ago
10 years ago

People

(Reporter: Bryan, Assigned: Kevin Gerich)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050811 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050811 Firefox/1.0+

Setting homepage to about:blank causes toolbar to jump/bounce briefly when
clicking on home or entering an address and hitting enter.  

Reproducible: Always

Steps to Reproduce:
1) Set homepage to about:blank and CLOSE FF
2) Launch FF (Latest build)
3) Click on the home icon on the toolbar
4) You should see the jumping issue;  if not go to step 5
5) Close and restart FF
6) Type in about:cache and hit enter; you should see the jumping issue...

Actual Results:  
The WHOLE toolbar jumps up about 1 pixel and only does it this one time until
you close and restart FF.  This occurs with both a new and old profile!

Expected Results:  
The toolbar shouldn't jump!  :-)

If I add the following to browser.css the issue is resolved:
 
  margin-top: -1px !important;
  margin-bottom: -1px !important;

Like so, here:
 
/* ::::: throbber ::::: */
 
#navigator-throbber {
  -moz-appearance: none;
  -moz-user-focus: ignore;
  margin: 0 !important;
  margin-top: -1px !important;
  margin-bottom: -1px !important;
  border: none !important;
  padding: 0px !important;
  min-width: 0;
  background-color: transparent;
  list-style-image: url("chrome://browser/skin/Throbber-small.png");
}

This is a direct result of 253661 landing.  That patch adjusts the menubar
height to resolve spacing issues.  If we were to add the above mentioned
solution then that will resolve another "jumping" issue when switching (ALT-tab
between the two and you'll see the File, Edit, View, menubar jump) between FF
and the Bookmark Manager (Bookmark Manager menu bar has a lower total height I
believe).

Kevin requested that this be assigned to him directly.
(Reporter)

Comment 1

13 years ago
I forgot to mention that removing the throbber also resolves this issue!  :-)

~B
Assignee: nobody → kevin
(Reporter)

Comment 3

13 years ago
Just in case it's not clear in my original comment this is caused by the
throbber.  If you remove it, the issue never occurs.  A fix coming up soon!

~B
(Assignee)

Comment 4

13 years ago
Are you sure this is *caused* by the throbber? If this happened as a result of
253661 landing, it would be very helpful to know which specific change triggers
the bug so we can make sure we're applying the right fix. 
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> Are you sure this is *caused* by the throbber? If this happened as a result of
> 253661 landing, it would be very helpful to know which specific change triggers
> the bug so we can make sure we're applying the right fix. 

Got a much better solution now Kevin.  Simply adding " padding-top: 1px; "
to the following code as shown resolves the issue:

CODE BEFORE:

.menubar-text {
  margin-top: 1px;
  -moz-margin-end: 4px;
  margin-bottom: 1px;
  -moz-margin-start: 5px;
  color: inherit;
}

CODE AFTER:

.menubar-text {
  margin-top: 1px;
  -moz-margin-end: 4px;
  margin-bottom: 1px;
  -moz-margin-start: 5px;
  padding-top: 1px;
  color: inherit;
}

Thanks to Aaron for helping with this!

I'll have a patch in the next day or two to resolve this issue!

~B

*** This bug has been marked as a duplicate of 304245 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.