regression: Vertical scrollbar draws over left of toolbar when using scrollbar while certain pages are loading

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: waynegwoods, Assigned: mark)

Tracking

({regression})

Trunk
PowerPC
Mac OS X
regression
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
This seems to be another issue with timing and native widgets, related to the
now-fixed bug 298677. Tested with the latest trunk nightly, in OS X 10.4.2.

When I load certain pages, and start moving the scrollbar before the page is
finished loading, sometimes the scroller very briefly pauses, then "jumps" a
tiny bit, and a scrollbar artefact appears in the top left-hand corner of the
window, over the toolbar (and the tab bar if it's open). So the symptoms are
identical to bug 298677, even though the method of reproducing is a bit different.

The bug doesn't manifest immediately upon using the scroller. Instead it seems
to occur at a certain point during loading. So to be sure of seeing it, you
should keep the scrollbar moving while the page loads.

I can't reproduce it 100% of the time, but at least I now have two pages in
which I can reproduce it more often than not. It seems to be related to download
timing as well, since if I save the pages locally, I can't seem to reproduce it.
This makes it very hard for me to produce a reduced test case, sorry!

Anyway, aside from the World Expeditions one above, there's also:
http://www.ffbooks.co.uk/n9/n48594.htm

With this page, I can't be certain, but the bug seems to occur as soon as the
iframe in the middle of the page (just under the "Second hand availability.."
bit) loads its left and bottom scrollbar borders. It doesn't actually display a
scroller, since the frame info is small enough to not require scrolling, but the
gutters still appear.

Again, sorry I can't be more explicit with the cause, since I can't reproduce it
with a page saved locally. But I'm hoping someone can find it useful!
Summary: regression: Vertical scrollbar draws over left of toolbar when using scrollbar while certain pages are loading → regression: Vertical scrollbar draws over left of toolbar when using scrollbar while certain pages are loading
I too have been seeing this, but couldn't reproduce reliably, so I didn't report
it. I now managed to reproduce it with the given URL on a 2005-08-10 nightly.
Flags: blocking1.8b4?

Updated

14 years ago
Flags: blocking1.8b4? → blocking1.8b4+
(Assignee)

Comment 2

14 years ago
Created attachment 193249 [details] [diff] [review]
Control draw event handler (for reference)

This is the control draw event handler from bug 298677, brought up to date.  It
causes bug 300058.  It solves this bug and bug 301478.

In my opinion, if this patch is the best that can be done, then we shouldn't
take it for release.  The tradeoff is between infrequent aesthetic problems of
moderate significance (without the event handler) and guaranteed aesthetic
problems of trivial significance (with it).  The former gives a more polished
feel.

Comment 3

14 years ago
Ditto what Mark said, I recommend dropping this from the blocker list. I don't
think we're going to do much better than the patch he has.
(Reporter)

Comment 4

14 years ago
I just observed another artefact with the scrollbar when the "blocked popup"
message is at the top of the page, but I haven't had a chance to define a proper
test case yet.

This might be a radical suggestion, but how about backing out the native
scrollbar widget just from the 1.5 branch? Or is it way too late for that?

With proper native widget support planned for the near future, it just seems
that this widget was switched too soon and probably should have only been added
to the trunk. But then, maybe there were other good reasons for it. I assume
switching it back would fix any ugliness for the next major release, though?

Comment 5

14 years ago
Per Josh this is as done as it can get for 1.5.
Flags: blocking1.8b4+ → blocking1.8b4-
(Reporter)

Comment 6

14 years ago
FYI filed the popup-related one as bug 306133
(Assignee)

Comment 7

13 years ago
I'm going to look at this again soon and see if there's a way to make it work without turds in scrollbars (bug 300058).

Comment 8

13 years ago
will this miss 1.5 release ?
(Assignee)

Comment 9

13 years ago
Apple says that the scrollbar turds are only present in 10.4.0 - 10.4.2 and will be fixed in an upcoming release.

With that in mind, I'll dust the draw event handler off.
(Assignee)

Updated

13 years ago
Assignee: joshmoz → mark
(Assignee)

Comment 10

13 years ago
Created attachment 201774 [details]
annoying iframe test page with lots of scrollbars

testcase for related issues
(Assignee)

Comment 11

13 years ago
This is fixed (trunk) by bug 311399.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Depends on: 311399

Updated

9 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.