[midas] iframe with designMode=on breaks when you navigate to another loaded page and then back

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: myk, Assigned: mats)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b5 -
blocking1.9 -
wanted1.9 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
When on a page containing an iframe with designMode=on, if you navigate to
another loaded page in that tab's history and then navigate back to the
designMode page, designMode no longer works (you can't type into the iframe).

Steps to Reproduce:

1. open attachment 192436 [details] (a simple testcase for designMode);
2. click in the iframe and type something;
3. go back to the previous page;
4. go forward to the designMode testcase;
5. type something, then click in the iframe to focus it and type something.

Expected Results: what you type in step 5 appears in the iframe, ideally before
you click in the iframe to focus it (it should have stayed focused), but
certainly afterwards.

Actual Results: what you type in step 5 doesn't appear in the iframe, either
before or after you click in the iframe to focus it.

Tested on today's nightly Linux build (Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.9a1) Gecko/20050816 Firefox/1.0+).

Note that if you load another page, then go back, designMode works.  But if you
subsequently go forward to that already-loaded page and then back, designMode
breaks.  So the problem is specific to navigating to an already-loaded page and
then back to the designMode page.
This is WFM when I have bfcache preffed off.
Blocks: 274784

Comment 2

14 years ago
Nominating 1.8b4 due to probable webpage breakage.
Flags: blocking1.8b4?
Keywords: regression

Comment 3

14 years ago
I suspect this is related to Bug 300411 which was fixing some designMode=on
issues with fastback.

Also see Bug 287707 which tracks some issues with designMode=on and fastback
which was already minused for this release.
Assignee: mozeditor → bryner

Comment 4

14 years ago
Bob or Brian - do you have a sense of whether existing usage of designMode are
impacted by this bug (i.e. blogger, etc).

Flags: blocking1.8b4? → blocking1.8b5?
(In reply to comment #4)
See <http://devedge-temp.mozilla.org/viewsource/2003/midas/01/> for more examples.

This bug affects not only the use of iframe but also when used on a full
document. In addition to |page->designmode page->back|, it affects
|designmodepage->new page->back|. designmode is turned back on if the page is
reloaded.

bfcache preserves the changes made to the designmode page, which are lost when
bfcache is off. In my opinion this will annoy people about the same as losing
their edits when navigating away and then back to the designmode page. One
additional problem with bfcache is that if you attempt to backspace thinking you
are editing the text on the page, it will navigate you backwards in your history
which might surprise people.

As for designmode usage, I don't have stats on how common it is but can say that
due to bug 198155 the use of an iframe was the recommended approach.

Comment 6

14 years ago
does this break blogger.com's wysiwyg editing because I think that's the largest
user of this feature that I know. 
Did some testing and couldn't get this to break on blogger or myspace blog
editing (8/29 build on Windows)... but it still seems likely to break some site
somewhere.

Updated

14 years ago
Flags: blocking1.8b5? → blocking1.8b5-
Flags: blocking1.9a1?

Comment 8

13 years ago
This bug can be reproduced with http://www.fckeditor.net/demo/default.html.
QA Contact: editor
(Assignee)

Updated

12 years ago
Duplicate of this bug: 382235
(Assignee)

Updated

12 years ago
Summary: iframe with designMode=on breaks when you navigate to another loaded page and then back → [midas] iframe with designMode=on breaks when you navigate to another loaded page and then back
(Assignee)

Comment 10

12 years ago
Posted patch Patch rev. 1Splinter Review
Assignee: bryner → mats.palmgren
Status: NEW → ASSIGNED
(Assignee)

Updated

12 years ago
Blocks: 351236
(Assignee)

Comment 11

12 years ago

Comment 12

12 years ago
Even in a page with DesignMode=ON that does not contain iframes we can reproduce this same situation. Please, try the attachment.

Comment 13

12 years ago
Adding myself to the CC list.
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
This is already fixed on trunk somehow, at least with current steps to reproduce.
(although this regressed on branch, bug 416751)
As a sidenote, I just found a case where designMode is still not working after going back, bug 419054. (slight different steps to reproduce than this one)

Updated

11 years ago
Blocks: 424615
Per comment #14.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.