Closed Bug 305166 Opened 15 years ago Closed 15 years ago

Crash when using the back button on pages with forms [@ nsNavigator::SetDocShell]

Categories

(Core :: DOM: Navigation, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: phiw2, Assigned: mrbkap)

References

()

Details

(Keywords: crash, regression, verified1.8)

Crash Data

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050818 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050818 Firefox/1.6a1

When navigating through pages with forms (the Mozillazine forums, Bugzilla), the
browser crashes when using the back button. Those pages contain forms (textarea,
input[type="text"]).

Fallout of bug 258285 ?

Didn't happen with yesterdays' build (0817).

Sorry, no Talkback ID, the 'Cadence' builds don't include it. I'll attach
Apple's crash log next

Reproducible: Always

Steps to Reproduce:
1. navigate through pages with forms
2. use the back button to go back
3.

Actual Results:  
crash

Expected Results:  
no crash, display page

This happens especially on pages with a textarea (such as forums).

Mac OS X, 10.3.9
Attached file Apple crash log
Assignee: nobody → general
Component: General → DOM: Level 0
Product: Firefox → Core
QA Contact: general → ian
Summary: Crash when using the back button on pages with forms → Crash when using the back button on pages with forms [@ nsNavigator::SetDocShell]
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050818
Firefox/1.6a1 ID:2005081816

Going back and forward between 7 bugzilla bugs WFM.
Bug 258285 was checked into trunk 2005-08-16 10:54 PDT so it can't be it.
This sounds more like bug 304882?  it is currently backed out since
2005-08-18 17:52 PDT so you should be able to tell soon...
Keywords: regression
Bug 258285 was the first thing that came to mind. I'm never 100% sure what the
actual timestamp is on those Cadence builds (build ID:0000000000). But that is
an other story.

That said, I've been browsing (with the same build as when I filed the bug) with
bfastcache disabled:
browser.sessionhistory.max_viewers: 0.
I didn't experience any crash.
Assignee: general → nobody
Component: DOM: Level 0 → History: Session
Flags: blocking1.8b4?
Keywords: crash
QA Contact: ian → history.session
No problems here
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050818
Firefox/1.6a1 ID:2005081823
Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.9a1) Gecko/20050819 Firefox/1.6a1

Confirmed on build 2005081901. This is a regression since 2005081801.
Looks like a regression from bug 304896
Blocks: 304896
When I disable Java-Script Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.9a1) Gecko/20050819 SeaMonkey/1.0a Mnenhy/0.7.2.10005 {Build ID:
2005081906} will crash while using the "Back" Button on every Page. 

Don't know if this was the same Bug, but the Stack looks a bit like this, so I
only add the TB-Incident: TB8523142G
Hope, that the Stack is helpful.
(In reply to comment #8)

> When I disable Java-Script Mozilla will crash while using the "Back" Button on 
> every Page. 

I can confirm this. No JS -> crash when hit 'back' Button in the browser. No
crash, when JS is anabled.

For me this is a blocker for SeaMonkey too!
Could this have been fixed with my recent checkin (to null-check mNavigator)?
(In reply to comment #10)
> Could this have been fixed with my recent checkin (to null-check mNavigator)?

Will try this soon, but CREATURE is just not ready with the relevant Build. :-(
Assignee: nobody → mrbkap
Flags: blocking1.8b4? → blocking1.8b4+
Bah, with disabled Java-Script its not fair to reply ;-) 
(In reply to comment #10)

> Could this have been fixed with my recent checkin (to null-check mNavigator)?

Yes, thanks Blake, your Patch has fixed this Issue almost for me using
CREATURE-Tinderbox-Build 2005081911.  Think we can close this one here soon.

(But Bug 305183 is really annoying when I would like to add this here)
seY



k
(In reply to comment #12)

> Yes, thanks Blake, your Patch has fixed this Issue almost for me using
> CREATURE-Tinderbox-Build 2005081911.  Think we can close this one here soon.

ACK. No crashes anymore.
Marking as fixed. Thanks for testing and sorry for the inconvenience.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
*** Bug 305293 has been marked as a duplicate of this bug. ***
This also affected Seamonkey/FF Trunk on Win32.
OS: MacOS X → All
Hardware: Macintosh → All
Flags: blocking1.8b4rc?
Flags: blocking1.8b4rc?
Keywords: fixed1.8
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051003 
Firefox/1.4.1

verified fixed
Keywords: fixed1.8verified1.8
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
Crash Signature: [@ nsNavigator::SetDocShell]
You need to log in before you can comment on or make changes to this bug.