Fails to open compose window (error) [Trunk Only]

RESOLVED DUPLICATE of bug 306379

Status

Thunderbird
Message Compose Window
--
blocker
RESOLVED DUPLICATE of bug 306379
13 years ago
13 years ago

People

(Reporter: Mike Cowperthwaite, Assigned: Scott MacGregor)

Tracking

({regression})

Trunk
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
TB 1.6a1-0820, Win2K

Attempting to open a compose window, I get the following:
 "An error occurred while creating a message compose window. Please try again."
'Trying again,' unsurprisingly, is an exercise in futility.


No error in JS console.  Same problem for plain and HTML compose, for New, Reply 
or Edit-as-New.

This is the 3rd nightly in a row I've downloaded that's been fubar, with a 
different problem each time.
(Assignee)

Comment 1

13 years ago
I see this too on a trunk build.

JavaScript error: , line 0: uncaught exception: [Exception... "Cannot find inter
face information for parameter arg 4 [nsIMsgComposeService.OpenComposeWindow]"
nsresult: "0x80570006 (NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)"  location: "JS f
rame :: chrome://messenger/content/mailCommands.js :: ComposeMessage :: line 186
"  data: no]

Severity: critical → blocker
Keywords: regression
Summary: Fails to open compose window (error) → Fails to open compose window (error) [Trunk Only]
(Assignee)

Comment 2

13 years ago
actually I'm not seeing this in a clean debug build.

I'll try a trunk nightly when I have some time.
(Assignee)

Comment 3

13 years ago
do you have any JS errors Mike?

(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> do you have any JS errors Mike?

Already answered that: no, just the popup error.
(Assignee)

Comment 5

13 years ago
this is still working for me branch and trunk

both mac and windows builds tested.

I haven't seen anyone else in the forums report having problems opening a
compose window either. 

extensions? a curseed profile?
(Reporter)

Comment 6

13 years ago
> extensions?

The only extension is Talkback 1.6, which I get complaints about every time I 
start up TB 0806.

> a curseed profile?

Unlikely, but who knows?  0806 runs as well as it did before I started fooling 
around with post-branch trunk builds.

Unfortunately, I can't test for another week because I'll be out of town.  I'll 
report back after I get a chance to catch up next week.
(Reporter)

Comment 7

13 years ago
OK, I've had a chance to test with a more current build.  I still get the 
problem, but it is restricted to just my regular profile.  I removed a couple of 
potentially problematic settings in prefs.js but saw no improvement.  I get the 
error no matter which identity will be used, so I guess it's not an identity-
specific pref.

I really don't want to have to rebuild this profile, Scott.  Got any hints on 
what I can look at to tweak it?
(Assignee)

Comment 8

13 years ago
feel free to send me your prefs file and I'll skim through it.
(Reporter)

Comment 9

13 years ago
OK, I found it: I noticed the dupe in the Bonsai Watch listing, restored the 
Spell Check button, and voilá, my compose window opens again.

*** This bug has been marked as a duplicate of 306379 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.