Nested SVG rotate transform does not display element contained

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
13 years ago
5 years ago

People

(Reporter: Anand Chelian, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050816 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050816 Firefox/1.0+

<?xml version="1.0" encoding="UTF-8"?>
<svg xmlns="http://www.w3.org/2000/svg"
    xmlns:xlink="http://www.w3.org/1999/xlink"
    width="800" height="600">
  <symbol id="testRect">
    <rect x="0" y="0" height="100" width="100" fill="black"/>
  </symbol>
  <use xlink:href="#testRect"/>
  <g transform="translate(0, 150)">
    <use xlink:href="#testRect"/>
  </g>
  <g transform="translate(150, 125)">
    <g transform="scale(.5)">
      <use xlink:href="#testRect"/>
    </g>
  </g>
  <g transform="translate(250, 125)">
    <g transform="rotate(45 50 50)">
      <use xlink:href="#testRect"/>
    </g>
  </g>
</svg>

Reproducible: Always

Steps to Reproduce:
1.Open file (Included in details section).


Actual Results:  
No 4th rectangle.


Expected Results:  
There should be a 4th rectangle rotated 45 degrees down.
Downloaded Batik to check.  It showed up in Batik.
Assignee: nobody → general
Component: General → SVG
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → Trunk

Comment 1

13 years ago
Works fine on linux, seems to be a problem with cairo on the Mac.

Updated

13 years ago
Depends on: 307155

Comment 2

13 years ago
Created attachment 196671 [details]
test file

works good in Windoze

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050912
Firefox/1.6a1
Brian, would you mind quickly checking if you can see the fourth (rotated) rect on an up to date trunk build on Mac?

Comment 4

11 years ago
(In reply to comment #3)
> Brian, would you mind quickly checking if you can see the fourth (rotated) rect
> on an up to date trunk build on Mac?
> 

WFM 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

up to date enough? There hasn't been a cairo resync since the beta afaik
Perfect, thanks (and yeah, no cairo update recently). In that case closing as worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 6

11 years ago
Nice work, everything OK. Many thanks!
---
MAC OS 10.4.10
---
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.4; en-US; rv:1.9b2pre) Gecko/2007112604 Minefield/3.0b2pre
You need to log in before you can comment on or make changes to this bug.