The default bug view has changed. See this FAQ.

Update cairo on branch to 1.0.0

RESOLVED FIXED

Status

Core Graveyard
GFX
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: tor, Assigned: tor)

Tracking

({fixed1.8})

1.8 Branch
fixed1.8
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

259.45 KB, application/octet-stream
vlad
: review+
Mike Schroepfer
: approval1.8b5+
Details
(Assignee)

Description

12 years ago
Cairo 1.0.0 fixes a problem with clipping on OS-X that affects SVG (non-trivial
clip area causes nothing to be drawn, triggerable by inner <svg>, <image>,
markers, <clipPath>, most <use> cases).
(Assignee)

Comment 1

12 years ago
Created attachment 194974 [details]
update branch cairo to 1.0.0

Includes one-liner change to svg cairo renderer for cairo API change (drawing
text advances point).  Test built on linux, os-x, and win32.
(Assignee)

Comment 2

12 years ago
*** Bug 308116 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

12 years ago
Created attachment 197062 [details]
updated diff
Attachment #194974 - Attachment is obsolete: true
Attachment #197062 - Flags: review?(vladimir)
(Assignee)

Updated

12 years ago
Attachment #197062 - Attachment is patch: false
Attachment #197062 - Attachment mime type: text/plain → application/octet-stream
Comment on attachment 197062 [details]
updated diff

I've got 1.0 merged on the branch in a local tree here; the trunk I'd rather
just merge pav and mine's cairo work from monotone in shortly (which has a
1.0.2-ish cairo from CVS).  I also got rid of mozstdint.h, so we don't have to
carry that around any more (I'll submit that patch to cairo upstream as well).

Gonna r=vladimir and request 1.8b5 approval, to do the final checkins there.
Attachment #197062 - Flags: review?(vladimir)
Attachment #197062 - Flags: review+
Attachment #197062 - Flags: approval1.8b5?

Comment 5

12 years ago
Comment on attachment 197062 [details]
updated diff

Approved per discussion on drivers.
Attachment #197062 - Flags: approval1.8b5? → approval1.8b5+

Updated

12 years ago
Flags: blocking1.8b5+
I'm running into problems with the VC71-built pixman lib; still working on
resolving those.  I'll get this in as soon as that's fixed.
Fixed on branch.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.