Status

Core Graveyard
GFX: Gtk
--
critical
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: stevee, Assigned: vlad)

Tracking

({mlk, regression})

Trunk
x86
Linux
mlk, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
From
  RLk:1.08KB
  Lk:332KB
  MH:7.98MB
  A:222K

To
  RLk:65.7KB
  Lk:421KB
  MH:7.83MB
  A:211K

According to Tinderbox, regression range is
http://tinderbox.mozilla.org/bonsai/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-08-22+14&maxdate=2005-08-22+23%3A59&cvsroot=%2Fcvsroot
(Reporter)

Comment 1

12 years ago
Regression range between 2005-08-22 14:59:50 & 2005-08-22 23:43

Updated

12 years ago
Severity: normal → critical
(Reporter)

Comment 2

12 years ago
Looks like it has jumped again, now to
  RLk:65.2KB
  Lk:696KB
  MH:8.13MB
  A:228K

between 23/08/2005 07:32:00 and 23/08/2005 09:23:00
Two checkins between these times; bug 276727 and bug 294114.
From the tinderbox log, the first jump was:

--NEW-LEAKS-----------------------------------leaks------leaks%-----------------------
nsFontGTK                                     45840          -
nsBasicEncoder                                  120          -
nsPersistentProperties                          176          -
nsFontCache                                      32          -
nsScreenManagerGtk                               20          -
nsSupportsArray                                  56          -
nsPref                                           44          -
nsRegionGTK                                     480          -
nsRenderingContextGTK                          4200          -
nsHashKey                                      2080          -
nsExtensibleStringBundle                         24          -
nsScreenGtk                                      48          -
nsCharsetConverterManager                        20          -
nsDrawingSurfaceGTK                            3240          -
nsSaveAsCharset                                  40          -
nsCStringKey                                   5200          -
nsPrefBranch                                    128          -
nsHashtable                                     440          -
nsEntityConverter                                20          -
nsFontMetricsGTK                                784          -
nsUnicodeEncodeHelper                            72          -
nsStringBundle                                   80          -
nsPrefService                                    44          -
DeviceContextImpl                               152          -
nsVoidArray                                    2520   31400.00%
AtomImpl                                        240     400.00%
nsLocalFile                                     600      25.00%

This sounds like the gfx landing...
Assignee: nobody → blizzard
Component: General → GFX: Gtk
OS: Windows 2000 → Linux
Product: Firefox → Core
QA Contact: general → gtk
This is probably related to the opacity issue in bug 305632; taking this one as
well..
Assignee: blizzard → vladimir
The second jump doesn't have useful NEW-LEAKS stats since there was a red cycle
in the middle; I think we should fix the gfx stuff and then see what things look
like.
Flags: blocking1.9a1+
It looks like my checkin for 305632 fixed this, but I'll let bz confirm and
close this when he wakes up.
Yeah, this looks fixed.  There are some remaining leaks that got added sometime
while this bug was present (any time the Rlk number jumps to 1.34 on Balsa), but
I suspect they're caused by a separate bug.  I just wish we knew which one.  :(

Comment 8

12 years ago
Fixed per comment 6. ->FIXED
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Flags: blocking1.9a1+
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.