Last Comment Bug 306175 - SeaMonkey should offer to migrate Thunderbird profile
: SeaMonkey should offer to migrate Thunderbird profile
Status: RESOLVED FIXED
:
Product: Core Graveyard
Classification: Graveyard
Component: Profile: Migration (show other bugs)
: Trunk
: x86 All
-- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 378460 (view as bug list)
Depends on: suiterunner 329744
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-27 09:39 PDT by Karsten Düsterloh
Modified: 2016-06-03 14:22 PDT (History)
14 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Karsten Düsterloh 2005-08-27 09:39:40 PDT
Just as Thunderbird offers to migrate Mozilla profiles, we should have an
end-user-friendly way to migrate Thunderbird's profile data into a SeaMonkey
profile. 
This option should both be available on startup of a new SeaMonkey profile and
as part of data import.
Comment 1 User image Worcester12345 2006-01-05 07:43:26 PST
Additionally, there should be a way to import from Thunderbird TO Thunderbird.

I didn't see another bug on this, so am adding it here. 
Comment 2 User image Mark Banner (:standard8) 2006-01-07 14:37:42 PST
(In reply to comment #1)
> Additionally, there should be a way to import from Thunderbird TO Thunderbird.
> 
> I didn't see another bug on this, so am adding it here. 
> 

This bug is about migration of a Thunderbird profile to SeaMonkey - ie what SeaMonkey can do with profiles, it isn't about what Thunderbird does with profiles.
Comment 3 User image Taran Rampersad 2006-01-31 12:25:52 PST
Concur. On January 9th, I changed to the Firefox/Thunderbird combo while awaiting release of SeaMonkey. When I *upgraded* (smile) to SeaMonkey today, email was started off as of January 9th. Since I know how to maneuver the file system, I simply copied the files for each account from the Thunderbird profiles to the Mozilla profiles, which got me up to date.

I would suggest checking for Thunderbird during install, and checking the date of the files to see if there is a notable difference. If there is, Thunderbird files should probably be copied to the Moz profiles.

And while I'm at it, can we stop calling it Mozilla and call it SeaMonkey? Darned thing is confusing when hacking the file system.
Comment 4 User image Mark Banner (:standard8) 2006-08-03 14:02:08 PDT
Once we implement SeaMonkey as an xul application (Bug 328887), and fix bug 329744, doing the Thunderbird migration will be easy (there's already a wip patch on bug 329744). Adding relevant dependencies.
Comment 5 User image Eyal Rozenberg 2006-12-17 13:51:57 PST
We need to consider what happens when there's both an old sm profile (or even an ns4 profile if there's still migration from that) and a tb profile. Are they to be merged? Do you select one of them for importing? Can you change your mind later and also import the other one? etc.
Comment 6 User image Mark Banner (:standard8) 2007-04-23 08:52:40 PDT
*** Bug 378460 has been marked as a duplicate of this bug. ***
Comment 7 User image Jonathan Pritchard 2007-05-03 11:53:24 PDT
(In reply to comment #1)
> Additionally, there should be a way to import from Thunderbird TO Thunderbird.
> 
> I didn't see another bug on this, so am adding it here. 
> 

The code however, could possibly be utilised by the Thunderbird team, since Thunderbird - Thunderbird migration has been requested for a long time.
Comment 8 User image Mark Banner (:standard8) 2007-05-20 10:44:48 PDT
This bug has now been fixed by bug 329744 for suiterunner builds ready for when they go live on trunk.
Comment 9 User image Worcester12345 2007-05-25 18:35:33 PDT
(In reply to comment #2)
> (In reply to comment #1)
> > Additionally, there should be a way to import from Thunderbird TO Thunderbird.
> > 
> > I didn't see another bug on this, so am adding it here. 
> > 
> 
> This bug is about migration of a Thunderbird profile to SeaMonkey - ie what
> SeaMonkey can do with profiles, it isn't about what Thunderbird does with
> profiles.
> 

(In reply to comment #7)
> (In reply to comment #1)
> > Additionally, there should be a way to import from Thunderbird TO Thunderbird.
> > 
> > I didn't see another bug on this, so am adding it here. 
> > 
> 
> The code however, could possibly be utilised by the Thunderbird team, since
> Thunderbird - Thunderbird migration has been requested for a long time.
> 


Well, since I couldn't find it, I created the true Thunderbird version of this bug:
Bug 382080 – Thunderbird should offer to migrate Thunderbird profile

Note You need to log in before you can comment on or make changes to this bug.