Calendar entries are sometimes displayed in a strange way, when there is more than one entry per day

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Jens Wannenmacher, Assigned: Mostafa Hosseini)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

When I create multiple entries for one day (events), the entries are displayed
like stairs (see screenshot). In the week-view they become nearly unreadable.
The problem seems to appear when entering events that don't start on full hours.
All events following are displayed badly too, even if they start on a full hour.

Best regards,
Jens

Reproducible: Always

Steps to Reproduce:
1. create an event that starts on 9:00 and ends on 10:00
2. create an event that starts on 10:30 and ends on 10:50
3. create an event that starts on 11:00 and ends on 12:00

Actual Results:  
events are displayed like stairs
(Reporter)

Comment 1

12 years ago
Created attachment 194161 [details]
attached a screenshot of the problem

Comment 2

12 years ago
I've seen this bug before, but I can't find at the moment. Can you please search
for dupes.

Comment 3

12 years ago
Could this be a duplicate of bug 251771?
Component: General → Sunbird and Calendar-Extension Front End
QA Contact: general → sunbird

Comment 4

12 years ago
I'm assuming this is off a nightly build, since 0.2 did a better job of this. 
If that is the case, then I'd like to remind you of the Roadmap's statement:

"Note on sunbird 0.3a1: This release has old views and stuff. Those views are
fixed to a point where the events show up, but there might be glitches in the
display. This release is not meant to test the views, but to test the calendar
backend code. Please don't file bugs on misaligned event boxes, wrong colors or
whatever looks wrong. Please do file bugs on events not showing up, events
showing up with wrong times, crashes, hangs, errors etc."

Therefore, there's no real duplicate of this.  It's essentially WONTFIX in my mind.
This bugs makes the view ugly and unusable enough that we need to fix it before
releasing 0.3a1. Minor glitches need no fix, but this is really big and really ugly.
Blocks: 298936
Created attachment 194199 [details] [diff] [review]
patch v1

calIDateTime.compare returns -1,0 or 1. Not true or false. Patch adds a
conversion.
Attachment #194199 - Flags: first-review?(jminta)

Comment 7

12 years ago
Comment on attachment 194199 [details] [diff] [review]
patch v1

Fantastic.
r=jminta
Attachment #194199 - Flags: first-review?(jminta) → first-review+
patch checked in.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.